Building LeMaker Android 4.2 from Source

129 59259
Edited by lenny at Fri Jan 16, 2015 12:32

so i didn't get my gentoo system to compile this.. still not really sure why but after downgrading
and patching around in my system i lost patience and went down another path:

in case anyone with similar problems here is what i did
download this VM for virtualbox ... droid-rom-compiling

there is a guide how to set it up on an already installed ubuntu (not tested by me): ... ompile-android-roms

u should be able to do this with any ubuntu installation but this is the way i did it.

boot into the system, open a terminal (password is: android)

  1. sudo su
  2. git clone ANDROID
Copy the Code
in another terminal do (idk if all of these is needed did just copy paste them from script):

  1. sudo su
  2. apt-get update
  3. apt-get upgrade
  4. apt-get install -y python-software-properties
  5. add-apt-repository -y ppa:webupd8team/java
  6. apt-get update -y
  7. apt-get install -y git-core gnupg flex bison gperf build-essential zip curl \
  8.         zlib1g-dev libc6-dev lib32ncurses5-dev lib32z1 lib32ncurses5 lib32bz2-1.0 \
  9.         x11proto-core-dev libx11-dev lib32z1-dev libgl1-mesa-dev g++-multilib mingw32 \
  10.         tofrodos python-markdown libxml2-utils libglapi-mesa:i386 u-boot-tools \
  11.         oracle-java6-installer libswitch-perl xsltproc
Copy the Code
after this part is finished..

  1. wget -o make.tar.gz
  2. tar -xvzf make-3.81.tar.gz
  3. cd make-3.81
  4. ./configure
  5. make install
Copy the Code
since u will have make version 4.0 and apparently android doesn't like it but will not notify visibly
when using "scripts/"
now you should be all set and able to follow the step-by-step guide from the first post.

this way everyone with a working virtualbox installation should be able to compile android 4.2 without
the need of completely crippling your own system.

cheers and thanks to
liab, zrox, dlanor, tony_zhang, ChrisP and mattrix for all their efforts keep on compiling ;)

Don.t forget liab for the last massive addition ;)

Hi ChrisP

Please insert in the liab git in the /lichee/linux-3.4/
.config file one line

Thank you.

Edited by liab at Sat Jan 17, 2015 00:08

Hi ChrisP, I'm here again.

In the android liab git is something wrong, the same in your git I cloned on Tuesday. The folders:


are not present. Could it be you delete all "out" folders before upload to the git?

After I repaired it works.

Edit 2:
I found a new mistake. The driver from the Realtek rtl8192eu will not work. At the moment I don't know exact why, i shall search it on sunday.

Hi ChrisP, the rtl8192eu sources was my fault, please excuse me. My test one rtl8192eu-geht was the right one. Please change it in the git. Here is the working version:

Hi liab, let me go back home and I'll fix it (I'm on travel right now)

Btw, I repeat my proposition to add your git account to the repo ;)

Ok, It should be ok right now.

Hi ChrisP
I tried in on monday it works. The only I don't understand in my original the 8192eu.ko is 3 411 692 B an with the clone git it is 3 413 783 B. I don't no why, but both are working.

Thank you for your proposition to add my git account to the repo. First I must improve to handle it. I tried to make a repository in my old gitorious account, but it gaves problems with "~" and spaces in the filename.

ChrisP replied at Sun Jan 18, 2015 12:23
Ok, It should be ok right now.

Good, but exactly what does "It" refer to here...?

What I mean is, exactly what git commands do we need to insert as replacement for existing ones in the current 'how-to' guides and/or VM-based scripts for making a good build from these sources ?

There has been some confusion about what sources and repos to use in the past, and at this point I'm not even certain what github account it is that holds the best sources, and even less sure what branch of it to specify in using them.

I'd like to get more active in this again, but I need some pointers to get the right stuff.

Best regards: dlanor

Hi dlanor, I'll make a new thread to list the various sources available.

But the one we were talking about were this one:

You have to log in before you can reply Login | Sign Up

Points Rules