Bananian

How to enable ipv6?

6 3103
Hey,

I'm beginner regard linux and bananian. At home I got a new ipv6 router. On my windows machine I get an ipv6 address (via dhcp), but on my bananian I still get an ipv4 address. How can I configure bananian so it gets an ipv6 address?

Best regards,
M.
B17C0D3  
Edited by B17C0D3 at Tue Dec 9, 2014 21:54

on default it is enabled
first you have to check /etc/sysctl.conf
  1. net.ipv6.conf.all.disable_ipv6 = 0
  2. net.ipv6.conf.default.disable_ipv6 = 0
  3. net.ipv6.conf.lo.disable_ipv6 = 0
  4. net.ipv6.conf.eth0.disable_ipv6 = 0
Copy the Code
for example, this is my configuration of /etc/network/interfaces
  1. auto lo
  2. iface lo inet loopback
  3. auto eth0
  4. iface eth0 inet static
  5.         address 192.168.0.4
  6.         netmask 255.255.255.0
  7.         gateway 192.168.0.1
  8. iface eth0 inet6 auto
Copy the Code
also i dont know why but i had to edit the /etc/resolv.conf
  1. nameserver 192.168.0.1
  2. nameserver 8.8.8.8
  3. nameserver 2001:4860:4860::8888
Copy the Code
you can also check your ip's with the command ifconfig

When  IPv6 stateless address autoconfiguration (SLAAC) is enabled you don't have to configure anything at all.
IPv6 is enabled by default.

Edited by planschmuh at Wed Dec 10, 2014 06:37

Hey,

on default it is enabled
first you have to check /etc/sysctl.conf


okay, these entries were missing, so I've added them.

My /etc/interfaces looks like:

  1. auto lo
  2. iface lo inet loopback

  3. auto eth0
  4. allow-hotplug eth0

  5. # dhcp configuration
  6. iface eth0 inet6 auto
  7. iface eth0 inet auto


Copy the Code
And I have also added the nameservers. But when I do 'ifconfig -a', there is only a ipv4 ip-address @eth0
  1. ifconfig -a
  2. eth0      Link encap:Ethernet  HWaddr 02:c8:07:01:a6:13
  3.           inet addr:192.168.20.27  Bcast:192.168.20.255  Mask:255.255.255.0
  4.           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
  5.           RX packets:1293 errors:0 dropped:0 overruns:0 frame:0
  6.           TX packets:2674 errors:0 dropped:0 overruns:0 carrier:0
  7.           collisions:0 txqueuelen:1000
  8.           RX bytes:434354 (424.1 KiB)  TX bytes:2919616 (2.7 MiB)
  9.           Interrupt:117 Base address:0xc000

  10. lo        Link encap:Local Loopback
  11.           inet addr:127.0.0.1  Mask:255.0.0.0
  12.           inet6 addr: ::1/128 Scope:Host
  13.           UP LOOPBACK RUNNING  MTU:16436  Metric:1
  14.           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
  15.           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
  16.           collisions:0 txqueuelen:0
  17.           RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

  18. tunl0     Link encap:IPIP Tunnel  HWaddr
  19.           NOARP  MTU:1480  Metric:1
  20.           RX packets:0 errors:0 dropped:0 overruns:0 frame:0
  21.           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
  22.           collisions:0 txqueuelen:0
  23.           RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
Copy the Code
Do you have any other ideas?


When  IPv6 stateless address autoconfiguration (SLAAC) is enabled you don't have to configure anything at all.
IPv6 is enabled by default.


Could you explain it a little more? Do I have to enable slaac at my router or in bananian?

Thanks in advance

SLAAC needs to be enabled on your (IPv6) router.

SLAAC needs to be enabled on your (IPv6) router.


Yes, after searching a while, I found out that SLAAC is enabled and in windows7 I get an address via autoconfiguration, but still not in bananian.

Edited by planschmuh at Fri Dec 12, 2014 11:43

okay, I've solved the issue.

For anyone who got trouble with ipv6, just install the network-manager via
  1. apt-get install network-manager
Copy the Code
and remove the ethernet configuration in /etc/network/interfaces, because the interfaces will be configured by the network-manager.

Reboot with
  1. shutdown -r now
Copy the Code
and thats it.

You have to log in before you can reply Login | Sign Up

Points Rules