Working SD Cards

12 7719
Post Last Edited by Thepiman at 2014-7-4 12:22

I have just tried a 16gb Lexar SDHC card and it doesn't seem to work with the Banana Pi

Has anyone else found any cards that do not work or can list which ones do?

My mistake it was a problem with the image not working not the card!
I use SDisk Extreme HD Video 8G, SDisk Ultra 8G, Kingston  SDHC 8G.

I use SDisk Extreme HD Video 8G, SDisk Ultra 8G, Kingston  SDHC 8G.

After receiving my BPI I was wondering why none of provided Linux distos went no longer than kernel boot and sent me "error -110 whilst initialising sd card". The Transcend Class 6 SDHC 8Gb card was fully functional (using Raspberry Pi and my Macbook Air at least), but BPI did not boot.

So I bought SanDisk Ultra Class 10 SDHC 8Gb card and it works like a charm.

Maybe the Transcend Class 6 SDHC 8Gb don't like BPi.

I think, not really, cause kernel boots ok from FAT partition, and -110 error means timeout of the root one. So it seems that BPi tries to mount root partition too early. Maybe different timing may help, but I do not have resources to investigate it through.

I ever met once.  My solution was to re-format the SD and re-write the image.  That works to me.

Edited by artnsx at 2014-10-15 15:30

Is there a maximum size that will work?

I've tried on a 64gb microsd in an adapter and got nothing.  Tried the very same image in a 8gb regular sd and it worked.

to add: when put in a pc, the microsd card appears and looks exactly like the other one that works in the pi

Update: it is not the adapter because i tried with a different microSD card (16gb) and it worked.  is a 64gb card not supported?

I'm using a 16GB Lexar Premium Class 10 SDHC card (LSD16GBBEU200) without any problems. Haven't tried any other.

You have to log in before you can reply Login | Sign Up

Points Rules