Bananian

[Release] Bananian 14.11 for BPI-R1 (Router)

45 22271
mattrix  
Edited by mattrix at Thu Dec 18, 2014 15:16

Trying this fix I saw posted by mega on facebook

"Can you please re-try the operation and let us know your progress? Open your MEGA account in a Google Chrome browser. Just before you are about to click 'Download' of the affected file press F12 to open your JavaScript Console. The screen will divide. Type 'skipcheck=1' in the bottom line of the Console, click 'Enter' and then select the 'Download' in your MEGA account window."


that worked but the actual zip archive is still broken.
Must of not uploaded correctly

mattrix replied at Thu Dec 18, 2014 14:25
Giving me same link, you could try this workaround

https://www.youtube.com/watch?v=P_LAeJvWQrg

ok lets wait then ;)

mattrix  
Edited by mattrix at Thu Dec 18, 2014 21:39

Uploading now

New MEGA link up now in first post. (mega always sticks on 99% for a while then gives you the save file dialog)
Tested OK.

Uploading to google drive now as well.

TRY IT OUT!

Edited by notthematrix at Fri Dec 19, 2014 07:55

Looks like it does not want to boot and when trying to mount the ext4 image and do a tar cvfz I get IO eroors.....
looks like someething went wrong with backing it up.
best way to do is is just mount image om computer do a tar cvfz /tmp/image.tgz ./*  in that case anymody can just format the sd card partition
for the OS ,, the boot part can be as a image... since its all the same size....
There is simply to manny diffrent sdcard in the world Iam afraid....

FIXED it I needed to use cat matrix.img > /dev/sdX
dd failed for some reason
did you use dd bs=512 ???? om a sd card it is 1M normaly ;)
if you  try a dd image with bs 512 and try to write it with bs =1024 you get unexpected results;)

mattrix  
I didn't use dd. I modified the stock bananian image by mounting it and editing. So it will be whatever that uses

adam_c  
I received my Bpi-R1 in the post yesterday, downloaded this, and everything working well.

thanks guys for all your hard work getting this img working for the router.

This is great!!! Thank you a lot!!!

I got everything running - 5 port switch, server, 433 Mhz transmitter and so on!
Wonderful, I now removed one switch and my banana pi from the network!

mattrix  
Edited by mattrix at Sat Dec 20, 2014 23:07

How is everyone's speeds through the switch?

Mine seem very slow.

If i do Speedtest on the BPI itself, I get about 40 Mbps in.
But, if I simply bridge 2x of the ports, I get on the 2nd output port a maximum of 9.50 Mbps.

Any ideas?

UPDATE:

Looks like it's my laptop 10/100 ethernet port detects the connection as 10 Mbps.
However, my other 10/100/1000 USB3.0 adapter port detects it as 1000 Mbps.

Has anyone had the BPI router working with a 10/100 port and detecting as 100 Mbps?

It may just be my cable etc, but thinking it might be something with the router not allowing a 100 Mpbs connection (just 10 or 1000).

If I use the same cable straight into my switch, it connects at 100 Mpbs

UPDATE2:

Tried on another laptop that had a 10/100 ethernet card and that connected to the BPI-Router at 100 Mpbs so just something weird with my laptop I think


Thanks,

Matt

@10MBit there is no autodetection of speed and full/half duplex. The switch will fall to 10MBit/half duplex which is the minimal standard.

It is same if you got a wrong or bad cable. Maybe a driver update on the laptop will do the trick.

You have to log in before you can reply Login | Sign Up

Points Rules