Bananian

kernel panic, no init found - Banana Pi Pro - bananian-141102

9 3363
Hey guys, thank you for reading in advance...

OS doesn't become available because the boot-process stops.

I have bought a Banana Pi Pro. My Power Source is a TP-LINK UH720 7-Port USB 3.0 HUB + 2 powerports (2,4A), I tried with a 2A-Samsung as well. That didn't work though either.

My SD-Card is a Samsung Memory 32GB EVO MicroSDHC UHS-I Grade 1 Class 10 Memory Card (up to 48MB/s) with SD Adapter. My keyboard is a Perixx Periboard-716DE.
My downloaded version of bananian is: bananian-141102

I copied bananian onto the SD-Card with:
sudo dd if=/home/user/Downloads/bananian-141102.img of=/dev/sdc bs=1M && sync

Bananian shows two tuxes and seems to start booting, but stops with:
  1. [mmc-err] smc 0 err, cmd 5, RTO
Copy the Code
on top of the screen, 4* visible. Then says couple lines down:
  1. EXT4-fs (mmcblk0p2): recovery complete,
  2. EXT4-fs (mmcblk0p2): mounted filesystem with ordered data mode. Opts: (null),
  3. VFS: Mounted root (ext4 filesystem) on device 179:2.
  4. devtmpfs:mounted
  5. Freeing init memory: 229k
  6. Kernel panic - not syncing: No init found. Try passing init=option to kernel. See Linux Documentation /init.txt for guidance.
  7. [<c0015058>] (unwind_backtrace+0+0/0x134) from [<c05b1d08>] (panic+0xa=/0x1d4)
  8. [<c05b1d08>](panic+0xa0/0x1d4) from [<cc05b14dc>] (vfp_single_sump.part.1+0x0/0x44)
  9. [<c05b14dc>] (vfp_single_sump.part.1+0x0/0x44) from [<c0844a90>](kernel_init+0x23c/0x240)
  10. CPU0: stopping...
Copy the Code
If you need more info, I could add a picture.

Any idea? It's a little sad.
tkaiser  
You chose the wrong forum and have overseen that the support for the 'Pro' is currently in a very early state: https://www.bananian.org/hardware

Being an early adopter always leads to some frustration

According to this info you should wait until next Wednesday for updated BPI Pro images:
http://forum.lemaker.org/forum.p ... 92&fromuid=1602

@tkaiser, my wrong...should have read and clicked correctly...Is there a moderator to move my question to the bananian-part of this forum? Thank you!
@actkk2000: I will wait for the update then. Hopefully everything works for me then.  Thank you as well!

Merry xmas!

tkaiser  
Edited by tkaiser at Tue Dec 23, 2014 03:54
actkk2000 replied at Mon Dec 22, 2014 10:50
you should wait until next Wednesday for updated BPI Pro images


That announcement applies only to the 'official' LeMaker images, right?

Bananian's roadmap doesn't show a new release that early: https://dev.bananian.org/roadmap_page.php

And since the LeMaker guys seem to have failed to send Igor a 'Pro' it might take some time until the other good image will have support for the 'Pro'.

But as far as I understand normally the Pro should work with either image after simply exchanging script.bin (I did it exactly the same way with both Bananian and Igor's Debian image when I wanted support for Olimex A20-Lime2. Both images were ready after I exchanged script.bin as described in https://www.bananian.org/hardware). And after applying the hw_pack Bananian might be ready with Wi-Fi (and maybe BT).

Pro support (Wifi) is now in our GitHub repository: https://github.com/Bananian/linux-bananapi
Fex has also been upgraded: https://github.com/Bananian/fex

Compile it yourself or wait some days until we push the next upgrade with a kernel supporting Banana Pi, Banana Pro and BPI-R1!

@tkaiser and @bananian: Thank you for helping me where to look.
Roadmap (https://dev.bananian.org/roadmap_page.php)shows, that an Bananian Linux - 14.11.03 should be "downloadable" any minute.
I'm not yet able to format urls like tkaiser did.
Since I am not sure how I should compile the github-repositories, I think I'll just have to wait.
The readme at bananians github doesn't look like an easy three-step... configure, make, make install, especially since the kernel on my laptop doesn't match the bananian pi pro-s kernel...

But I'm looking forward to more information on the topic.

Happy new year everyone!

Hi herrmeier,

Bananian 14.11.03 has been postponed and will be a major release introducing support for the Banana Pro and the BPI-R1.
Meanwhile you can use my kernel snapshots for full hardware support:
http://forum.lemaker.org/forum.p ... amp;page=1#pid57327

Hi everyone, the new image solved my problem, but I'm stuck during configuration routine at the question:

Your current hardware configuration is: BananaPi
Do you want to change it? (y/N)


But I think I'll add a nue thread for that. Thank you anyway! How do I mark this thread solved?

hodoors  
Note: The author has been banned or deleted.

You have to log in before you can reply Login | Sign Up

Points Rules