Other OS

HOWTO: Get a working hardware accelerated video with gstreamer.

28 22740
MarcelS  
Beetlejuice replied at Fri Jan 30, 2015 12:08
Same problem for me, all is ok until "fatal error" ...
So i'm waiting for help too

I had the same problem, so I decided to compile libva from source. Then I was able to build gstreamer-vaapi, but something went wrong, because gst-inspect shows only one vaapi plugin:
vaapiparse:  vaapiparse_h264: H.264 parser

dizus  
michael replied at Mon Jan 19, 2015 09:26
Hello dizus:

First, thanks for your awesome tutorial. Finally, I can play 1080p video smoothly with ...

Not sure if it's still relevant, but considering the error messages I suppose it has something
to do with audio system, in particular Alsa. Make sure it's working, check permissions on audio device
or try running your pipeline as root.

dizus  
Edited by dizus at Wed Feb 18, 2015 04:18
randyf1965 replied at Thu Jan 29, 2015 05:15
Everything worked fine until I got to the gstreamer vaapi plugin, when I run make I get the follwing ...


I suppose every step up to compiling gstreamer vaapi plugin went well?
If so there must be some kind of changes made to the plugin source or raspbian packages.

First of all, I would double check if every apt package mentioned is installed.
Pay attention to development packages (those usually come with "dev" in the package name).
There may be a rare case when the some package was renamed or maybe split into a couple of packages,
though I highly doubt that. Verify that you didn't get any errors when installing those packages.

Second option, which is more likely, there have been some changes made to the plugin source code.
Since you are getting the source from the GIT repository your are getting the latest version. Try cloning
some older version and see if it you can compile it with out error.

Hope that helps a little. Unfortunately, I don't have much time to work with Banana Pi at the moment. Maybe I'll
try to go through the HOWTO and see if anything has changed since I wrote it.



Pegax  
The problem in compiling Vaapi is that libva-dev is older than what vaapi plugin wants.
You can however get older version from freedeskktop.org
(http://www.freedesktop.org/softw ... es/gstreamer-vaapi/) version 0.5.9 should compile fine within raspbian

Z9Zx  
2 dizus:
Nice job! Many thanks.
2 Pegax:
That's really works.

I'm verify this howto for OLinuXino A20.

can someone upload edited image for testing?

that is a awesome work ! Thank U !

Hi Dizus:
I've tried to follow your guide to create vdpau and I always find the same problem:
'vdpauinfo: cannot connect to X server.'

I've assured that:
/dev/cedar_dev is assigned to video group.
VDPAU_DRIVER=sunxi

What I've noticed is that xorg.0.log shows the message:
'no 3D acceleration because the driver has been compiled withot libUMP'

I'm using last image for Banana Pro instead of Banana Pi. Can be the cause?

karletes replied at Thu Sep 10, 2015 04:57
Hi Dizus:
I've tried to follow your guide to create vdpau and I always find the same problem:
'vdpa ...

Solved!
I was using root user. If I use bananapi user it works.

moncler outlet
louis vuitton outlet online
north face jackets
ugg boots
moncler outlet
ugg boots
nike store
supreme clothing
pandora jewelry
canada goose outlet
cheap uggs
michael kors outlet
coach outlet
pandora charms
louis vuitton outlet
adidas campus
adidas shoes
supreme clothing
coach outlet
adidas outlet
mulberry handbags
longchamp outlet
coach factory outlet
air jordans
polo ralph lauren outlet online
ralph lauren
birkenstocks
adidas outlet
ralph lauren outlet
pandora charms sale
cheap jordans
coach outlet
kate spade
burberry
nike outlet store
coach outlet
fitflops sale clearance
yeezy boost 350
ugg boots
adidas superstar
mcm handbags
adidas yeezy
coach outlet
nmd adidas
kate spade bags
coach outlet store
kate spade outlet
nike outlet
coach factorty outlet
ralph lauren outlet
supreme new york
canada goose jackets
canada goose outlet
cheap nba jerseys
cheap oakley sunglasses
ferragamo shoes
coach factory outlet
nike air max
mulberry outlet
coach factory outlet
hermes outlet
canada goose uk
timberland outlet
cheap mlb jerseys
coach outlet store
christian louboutin outlet
fitflops
mcm outlet
philipp plein outlet
michael kors factory outlet
air max 97
canada goose jackets
ralph lauren
moncler outlet
cheap nfl jerseys
cheap ray ban sunglasses
oakley sunglasses
ray ban sunglasses
michael kors outlet
moncler jackets
coach outlet store online clearances
pandora charms sale clearance
mlb jerseys
coach outlet
jordan shoes
michael kors outlet
air jordan shoes
cheap jordans free shipping
moncler jackets
coach outlet
adidas nmd
cheap nfl jerseys
adidas yeezy boost
coach outlet
ralph lauren uk
michael kors outlet
ecco shoes for men
michael kors outlet online
canada goose outlet
nike air max
pandora charms
hermens bags
ralph lauren outlet
yeezy 350 boost
canada goose outlet
converse outlet store
ralph lauren uk
canada goose sale
ugg boots on sale
ultra boost
coach outlet
philipp plein shirt
ralph lauren outlet
air jordan shoes
michael kors outlet clearance
canada goose outlet
kate spade outlet store
birkenstock sandals
180309yueqin

You have to log in before you can reply Login | Sign Up

Points Rules