XMBC

XBMC / Linux /Touchscreen

21 6235
ph87  
tony_zhang replied at Mon Dec 29, 2014 19:26
If we use the touchscreen with the i2c interface, we do not need to configure any file.

I understand what you mean  But what is with those people who don't want that Touchscreen or just already have one without i2c?

ph87  
jogi36de replied at Tue Dec 30, 2014 05:34
Hello,

i had installed bananian (latest image) and than i have compiled successfully xbmc with no e ...

Thank you I've got a successful build on Lubuntu (don't know why I didn't do it on Bananian... )

Now I've applied the patches and the BPi is compiling just now onces again! I hope it works!!!

Btw... jogi36de,... are from Germany?

ph87  
Okay I've successfully compiled it with patches - problem is it doesn't work! I think it depends on the path for the calibration file which will be created by the patch...
Can someone tell me where the working directory for the xbmc is? I mean e.g when I install a addon  within xbmc where is the addon saved? I need the home directory that xbmc uses!

ph87 replied at Tue Dec 30, 2014 16:22
Thank you I've got a successful build on Lubuntu (don't know why I didn't do it on Bananian... ) ...

Hi,

yes i'm from germany

ph87  
Edited by ph87 at Wed Dec 31, 2014 08:35

So, this project fails at this part, that I don't know how this compiled XBMC works...
When I start xbmc with ./xbmc.bin it starts, but what is it's working directory?

I've to know where the location of the files from xbmc is e.g where are the installed addons are? what is the "root" folder from xbmc of it's system files ....

Can someone help me out please?

Hi

in /melehacking/xbmca10/tools/a10/depends/depends.mk  you can find following lines:

#your home dir
#HOME=$(shell echo ~)
HOME=/opt/a10hacking


#where is your xbmc install root
XBMCPREFIX=/allwinner/xbmc-pvr-bin$(HF)

I hope it can help.

best regards

Hello, i've tried to compile xbmc with patches from your post obove in Lubuntu. I have get one error on compiling. Something with filesystem and SmbFile.o is going wrong. you know what i mean? Can you help me or do you need the complete error message?

best regards

Hi,

i'm trying to compile XBMC with Lubuntu by my self. On the End of compiling i get this Error:

LD      xbmc.bin
xbmc/utils/utils.a: member xbmc/utils/utils.a(XBMCTinyXML.o) in archive is not an object
collect2: error: ld returned 1 exit status
make: *** [xbmc.bin] Error 1

Can anybody help me? What does this error mean? Mr. Google don't know ;(

my problem is solved. My Banana Pi runs perfect witch Lubuntu, xbmc and my touchscreen. It is used for my Van (Chevy Van G20). best thanks to ph87

another question. How can i autostart xbmc? everytime when i start Lubuntu i have to go to console and start /allwinner/xbmc......././xbmc.bin

regards

You have to log in before you can reply Login | Sign Up

Points Rules