Trouble

No boot

5 3595
Hi,
i am aware I am not the only one but I am sure that I did not make the mistakes that were obvious in the other threads.

I got my Banana Pi yesterday (from Ali-Express) and it included a 8GB class 10 SD Card, a case, a 2A power supply.

I downloaded several images from here (lemaker)..the new Lubuntu 3.0, the 2.0 image, also the Raspbian. I prepared the card with Win32DiskImager accordingly.

I have connected my computer screen via HDMI, put the SD in the Pi, put an ethernet cable in to my 1GBit Switch, attached a USB keyboard and then plugged in the power.

The only thing that happens is that the red led is on and that the LED on the ethernet jack blinks a bit (as expected, there is multicast streams in my network)

No Signal to HDMI. ALso tried the analog TV output later.

I have afterwards tried with 2 more SD card, one of them only 4GB. This 4GB card works however in my raspberry (of course only after flasing another IMG on it)

When I power on without the SD Card, the only difference is that the ethernet jack LEDs do not blink at all.

I have tried 1 more 5V 2A power adapter.

Is there any more ways to debug why it is not booting?

Only thing I did not try yet is to connect something to the UART.

I do also not see any DHCP leases on my DHCP server.
ok now i got UART with more information:
U-Boot SPL 2014.04-10691-g493a12c (Jun 25 2014 - 19:46:19)
Board: Bananapi
DRAM: 1024 MiB
CPU: 960000000Hz, AXI/AHB/APB: 3/2/2
spl: not an uImage at 1600


U-Boot 2014.04-10691-g493a12c (Jun 25 2014 - 19:46:19) Allwinner Technology

CPU:   Allwinner A20 (SUN7I)
Board: Bananapi
I2C:   ready
DRAM:  1 GiB
MMC:   SUNXI SD/MMC: 0
*** Warning - bad CRC, using default environment

In:    serial
Out:   serial
Err:   serial
Net:   dwmac.1c50000
Hit any key to stop autoboot:  0
reading uEnv.txt
344 bytes read in 17 ms (19.5 KiB/s)
Loaded environment from uEnv.txt
Running uenvcmd ...
reading /script.bin
52280 bytes read in 56 ms (911.1 KiB/s)
reading /uImage
Error reading cluster
** Unable to read file /uImage **
## Booting kernel from Legacy Image at 48000000 ...
   Image Name:   Linux-3.4.90
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    5138520 Bytes = 4.9 MiB
   Load Address: 40008000
   Entry Point:  40008000
   Verifying Checksum ... Bad Data CRC
ERROR: can't get kernel image!
** Can't read partition table on 0:0 **
** Invalid partition 1 **
** Can't read partition table on 0:0 **
** Invalid partition 1 **




question is why does this happen with several SD cards....any other way i could prepare/verify a card?

It is SD card problem.  The SD card may have some broken blocks. But most problem is the actual SD card size is less than the image size.

Reply 2# unimatrix27

Beforr u copy the image to yr card , is it .img?

unimatrix27 replied at Jul 06, 2014 04:57
ok now i got UART with more information:
U-Boot SPL 2014.04-10691-g493a12c (Jun 25 2014 - 19:46:19)
...

I had exactly the same error with 2 separate 16Gb SD cards, and then the 3rd card I tried worked perfectly!

banedos  
Edited by banedos at Feb 15, 2016 14:48

Try to format card with SdFormater tool.(with flags: file adjusment on, quick format on) I also had problem with SD, but after formatting with this tool - everything ok.

You have to log in before you can reply Login | Sign Up

Points Rules