Lubuntu

Irqbalance memory leak

7 1499
Ra:)  
Edited by Ra at Mon Dec 29, 2014 03:32

Somebody solved this somehow:
Leak.JPG
???
Rebooting device/service everyday - is not a solution for me (one used for logging purposes) and it isn't jedi's way.
The issue present with both "official" Lemaker kernels.
tkaiser  
You should simply disable irqbalanced since it's not working on ARM. A daemon that does nothing other than eating up CPU ressources and memory isn't that useful at all

tkaiser  
BTW: There exists a search field in this forum: http://forum.lemaker.org/search. ... balance+memory+leak

Ra:)  
Edited by Ra at Mon Dec 29, 2014 06:43

Already done, testing now...
/etc/default/irqbalance set to ENABLED=0
And yes, all irq's are on the CPU0 now...

tkaiser  
Ra:) replied at Mon Dec 29, 2014 06:36
Already done, testing now...
/etc/default/irqbalance set to ENABLED=0

BTW: If ENABLED=1 is the default with LeMaker's Lubuntu image then you should write a message to tony_zhang asking him for deactivation of irqbalanced. The reasons why were outlined in the other thread sharing the same subject in detail...

Ra:)  
tkaiser replied at Mon Dec 29, 2014 06:42
BTW: If ENABLED=1 is the default with LeMaker's Lubuntu image then you should write a message to t ...

Thanks! Done. Hope in future that will be fixed.

tkaiser  
Edited by tkaiser at Mon Dec 29, 2014 08:13
Ra replied at Mon Dec 29, 2014 06:36
all irq's are on the CPU0 now...


They've been there before because IRQ balancing does not work on ARM. Tosiara posted this after 12 hours uptime with irqbalanced enabled: http://pastebin.com/hSL2jEsu

It simply makes no difference whether irqbalanced is running or not. So disabling it seems to be the best choice...

hodoors  
Note: The author has been banned or deleted.

You have to log in before you can reply Login | Sign Up

Points Rules