Discussion

Banana Pro Access Point Mode

14 12619
niceday  
I have a Banana Pro.  The WIFI is working fine.  I try to setup Banana Pro as a router but failed.  I can scan and see my banana pro SSID but after I entered password, cannot connect to my banana pro.  Help?
hnsncxy  
Edited by hnsncxy at Fri Jan 9, 2015 23:29
I have a Banana Pro.  The WIFI is working fine.  I try to setup Banana Pro as a router but failed.  I can scan and see my banana pro SSID but after I entered password, cannot connect to my banana pro.  Help?

Hi,Niceday
The default hostapd tool have some problems,recommend you to use the below hostpad tool,as shown below
  1. git clone git://w1.fi/srv/git/hostap.git
  2. apt-get install libnl-dev
  3. cd hostap/hostapd
  4. cp defconfig .config
  5. make
Copy the Code
The configuration file of the hostapd as shown below
  1. vim /etc/hostapd/hostapd.conf
  2. interface=wlanx
  3. driver=nl80211
  4. ssid=ap6210_ap_test
  5. channel=6
  6. hw_mode=g
  7. macaddr_acl=0
  8. auth_algs=1
  9. ignore_broadcast_ssid=0
  10. wpa=3
  11. wpa_passphrase=12345678
  12. wpa_key_mgmt=WPA-PSK
  13. wpa_pairwise=TKIP
  14. rsn_pairwise=CCMP
Copy the Code

ProtonK  
Edited by ProtonK at Thu Jan 15, 2015 15:27

Hey guys, I have a similar problem with the BananaPro. I installed both the apt-get version of hostapd and the one stated by hnsncxy.
However, same problem with both version. The network appears but upon activation, it asks for the password repeatedly.
from
  1. hostapd -dd hostapd.conf
Copy the Code
I get as error
  1. nl80211: Event message available
  2. nl80211: Drv Event 20 (NL80211_CMD_DEL_STATION) received for wlan0
  3. nl80211: Delete station 58:94:6b:5e:56:dc
  4. wlan0: Event DISASSOC (1) received
  5. wlan0: STA 58:94:6b:5e:56:dc IEEE 802.11: disassociated
  6. wlan0: STA 58:94:6b:5e:56:dc WPA: event 2 notification
  7. wpa_driver_nl80211_set_key: ifindex=4 (wlan0) alg=0 addr=0x10d99e0 key_idx=0 set_tx=1 seq_len=0 key_len=0
  8.    addr=58:94:6b:5e:56:dc
  9. WPA: 58:94:6b:5e:56:dc WPA_PTK entering state DISCONNECTED
  10. WPA: 58:94:6b:5e:56:dc WPA_PTK entering state INITIALIZE
  11. wpa_driver_nl80211_set_key: ifindex=4 (wlan0) alg=0 addr=0x10d99e0 key_idx=0 set_tx=1 seq_len=0 key_len=0
  12.    addr=58:94:6b:5e:56:dc
  13. nl80211: Set STA flags - ifname=wlan0 addr=58:94:6b:5e:56:dc total_flags=0x0 flags_or=0x0 flags_and=0xfffffffe authorized=0
  14. wlan0: STA 58:94:6b:5e:56:dc IEEE 802.1X: unauthorizing port
  15. Could not set station 58:94:6b:5e:56:dc flags for kernel driver (errno=11).
  16. nl80211: sta_remove -> DEL_STATION wlan0 58:94:6b:5e:56:dc --> 0 (Success)
  17. ap_free_sta: cancel ap_handle_timer for 58:94:6b:5e:56:dc
Copy the Code
Any ideas?

hnsncxy  
ProtonK replied at Thu Jan 15, 2015 15:26
Hey guys, I have a similar problem with the BananaPro. I installed both the apt-get version of hosta ...

Hi, ProtonK
You need to set the AP mode when you load the wifi driver, as shown below:
  1. modprobe ap6210 op_mode=2
Copy the Code

ProtonK  
Thanks for the reply hnsncxy, but it didn't work with modprobe ap6210 op_mode=2.

I basically followed the instructions on
WiFi access point with Raspberry Pi
up to the point where hostapd comes into play.

I tried to set ap6210 to op_mode=2 manually and by changing /etc/modules, which only contains
  1. ap6210 op_mode=2
Copy the Code
Any ideas? Is there something else that needs to be set before loading the access point driver?

@hnsncxy: I think you have an typo in your hostapd.conf
  1. 10. wpa=2
Copy the Code
works for me.

Thanks!

hnsncxy  
Edited by hnsncxy at Mon Jan 19, 2015 22:09

bullet64 replied at Mon Jan 19, 2015 14:49
@hnsncxy: I think you have an typo in your hostapd.confworks for me.

Thanks!


Hi, bullet64
About the hostapd parameters, Please refer to the hostapd.conf from the http://w1.fi/hostapd/
  1. # This field is a bit field that can be used to enable WPA (IEEE 802.11i/D3.0)
  2. # and/or WPA2 (full IEEE 802.11i/RSN):
  3. # bit0 = WPA
  4. # bit1 = IEEE 802.11i/RSN (WPA2) (dot11RSNAEnabled)
  5. #wpa=1
Copy the Code
we can enable wpa and wpa2 by the below set
  1. wpa=3
Copy the Code
Thanks

hostapd.conf.rar (23.39 KB, Downloads: 70)

Thanks for the infos. For me it works only with wpa=2
I will do more tests....

ProtonK  
Thanks for pointing that out bullet64.

It also works for me with wpa=2.

hnsncxy  
Edited by hnsncxy at Tue Jan 20, 2015 23:14
ProtonK replied at Mon Jan 19, 2015 11:08
Thanks for the reply hnsncxy, but it didn't work with modprobe ap6210 op_mode=2.

I basically follow ...


Hi,
You can refer to the below steps which we have tested on the Raspbian System
Note: wlanx represent wlan0,wlan1 . . .
1)  Edit the /etc/modules
  1. root@lemaker:# vim /etc/modules
  2. #Display and GPU
  3. #lcd
  4. #hdmi
  5. ump
  6. #disp
  7. mali
  8. mali_drm
  9. ap6210 op_mode=2
Copy the Code
2)  Download and Compile the hostapd
  1. root@lemaker:# git clone git://w1.fi/srv/git/hostap.git
  2. root@lemaker:# sudo apt-get install libnl-dev
  3. root@lemaker:# cd hostap/hostapd
  4. root@lemaker:# cp defconfig .config
  5. root@lemaker:# make
  6. root@lemaker:# cp hostapd /usr/local/bin
Copy the Code
If you don't install the git tool on your system , please run apt-get install git at first.
3)  Create and Edit the hostapd.conf
  1. root@lemaker:# mkdir -p /etc/hostapd
  2. root@lemaker:# vim /etc/hostapd/hostapd.conf
  3. interface=wlanx
  4. driver=nl80211
  5. ssid=ap6210_ap_test
  6. channel=6
  7. hw_mode=g
  8. macaddr_acl=0
  9. auth_algs=1
  10. ignore_broadcast_ssid=0
  11. wpa=3
  12. wpa_passphrase=12345678
  13. wpa_key_mgmt=WPA-PSK
  14. wpa_pairwise=TKIP
  15. rsn_pairwise=CCMP
Copy the Code
4)  Edit the interfaces
  1. root@lemaker:# vim /etc/network/interfaces
  2. auto lo
  3. iface lo inet loopback
  4. iface eth0 inet dhcp

  5. #iface wlan0 inet manual
  6. #wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
  7. #iface default inet dhcp

  8. allow-hotplug wlanx
  9. iface wlanx inet static
  10. address 192.168.100.1
  11. netmask 255.255.255.0
Copy the Code
5)  Enable the DHCH Server
5.1  Install the DHCP Server
  1. root@lemaker:# sudo apt-get install udhcpd
Copy the Code
5.2   Edit the udhcpd.conf
  1. root@lemaker:# vim /etc/udhcpd.conf
  2. #The start and end of the IP lease block
  3. start    192.168.100.101    #default: 192.168.0.20
  4. end      192.168.100.254   #default: 192.168.0.254
  5. #The interface that udhcpd will use
  6. interface   wlanx     #default: eth0
  7. #Examles
  8. option  subnet  255.255.255.0
  9. opt     router  192.168.100.1
  10. opt     wins    192.168.100.1
  11. option  dns     192.168.100.1
  12. option  domain  local
  13. option  lease   864000
Copy the Code
6)  Reboot and Re-Login
6.1  Run the DHCP Server
  1. root@lemaker:# udhcpd /etc/udhcpd.conf
Copy the Code
6.2  Run the hostapd
  1. root@lemaker:# hostapd -B /etc/hostapd/hostapd.conf
Copy the Code
7)  Results show
7.1  View wireless interface
iwconfig.png

7.2  Client connect
client connect.png

7.3  Ping test
ping test.png

Thanks

You have to log in before you can reply Login | Sign Up

Points Rules