Bananian

Banana Pro with wifi can't see

6 3531
terrazo  
Edited by terrazo at Sun Jan 11, 2015 06:48

Hi sorry for my English ;)
I'm newbie and have problem with wif in my banana Proi. I installed last version banianan OS 15.01 http://dl.bananian.org/releases/ and no detet wlan0 i try previous version and nothing.
root@bananapi ~ # ifconfig
eth0      Link encap:Ethernet  HWaddr 02:d9:05:01:60:17
          inet addr:192.168.101.165  Bcast:192.168.101.255  Mask:255.255.255.0
          inet6 addr: fe80::d9:5ff:fe01:6017/64 Scopeink
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:102 errors:0 dropped:0 overruns:0 frame:0
          TX packets:102 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:12387 (12.0 KiB)  TX bytes:13711 (13.3 KiB)
          Interrupt:117 Base address:0xc000

lo        Link encapocal Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

root@bananapi ~ #
I have access to my banana pro only by terminal. Any idea what can i do to see wlan ??
thanks a lot for answer....
Edited by Bananian at Sun Jan 11, 2015 14:02

https://www.bananian.org/hardware#banana_pro and/or https://www.bananian.org/faq

terrazo  
Edited by terrazo at Sun Jan 11, 2015 08:29

Thx friend,
In terminal 'bananian-hardware' and i select BananaPro. I edit file /etc/modules and i add 'ap6210'.
Now 'ifconfig wlan0 up' and i see wlan0

But i have next problem with connect via wifi....
In terminal 'iwlist wlan0 scan'
I see my network and ssid.

root@bananapi ~ # wpa_passphrase NETGEAR >> /etc/wpa_supplicant.conf
mypass
root@bananapi ~ #   

root@bananapi ~# cat /etc/wpa_supplicant.conf
# reading passphrase from stdin
network={
ssid="NETGEAR"
#psk="mypass"
psk=42....20c
}
root@bananapi~# wpa_supplicant -B -D wext -i wlan0 -c /etc/wpa_supplicant.conf
ioctl[SIOCSIWENCODEEXT]: Invalid argument
ioctl[SIOCSIWENCODEEXT]: Invalid argument
root@bananapi~#iw wlan0 link
root@bananapi ~#

And not connected ;(
My network WIFI WPA2-PSK
Any idea ??

Wig  
Edited by Wig at Mon Jan 12, 2015 09:06

Hi,
I can't configure bananian-hardware.
If I select Banana Pro using the Arrow-Keys and hit return it says
Hardware configuration has been set to: BananaPi. Please reboot your system!


PS: First I tried it using SSH and then using a Monitor and Keyboard.

You have to select Banana Pro, press space to select and then return to confirm.

Wig  
Thank you. This worked.

You have to log in before you can reply Login | Sign Up

Points Rules