Trouble

Banana Pi always out of time

8 3837
Hi everyone

I have my Banana Pi quite a few month and everything is running well.
I installed a Raspbian, it is running on a Harddisk instead of SD Card and I am totally satisfied with the performance of this piece of hardware.

I just have one renaining problem.
The time on the Banana Pi is always out of sync. The time is always 10 minutes ahead and I am not able to correct the time.
I am using: the command
sudo date -s "Jan 17, 2015 14:00:05" to set the time but when I immidiately use the command date after this, the time is again 10 Minutes ahead.

Also when I use  the command: sudo ntpdate de.pool.ntp.org to get the time from a time server I am gettng this:

17 Jan 14:12:32 ntpdate[3866]: step time server 85.214.217.110 offset -528.712755 sec
when I am using the same command right after this command I am getting again:  17 Jan 14:13:36 ntpdate[3937]: step time server 83.170.1.42 offset -528.704160 sec
So finally, I am not able to modify the time by using any available method.

My system: System........: Linux bananapi 3.4.90 #2 SMP - Raspbian

What is always setting my time 10 minutes into the future ?
Yesterday I uninstalled fake-hwclock to find out if this caused the Problem, but with the same result.

Anyone any  Ideas
Always 10 minutes ahead.....
I am using ntp to sync the time, seems ok.

Edited by dreizehn at Mon Jan 19, 2015 08:57
tony_zhang replied at Sun Jan 18, 2015 19:59
Always 10 minutes ahead.....
I am using ntp to sync the time, seems ok.


Hi

I also used ntpd some weeks ago to sync the time with an external timeserver and connecting internal hosts to sync the time with the Banana Pi....but also with this deamon, my time jumps away into the future.
But anyway, right after the time is being set with the date command, it is being set back into the future.
I checked /var/log/messages or syslog but can not see any errors

Any other Idea whats wrong with my Banana pi ?

tkaiser  
Edited by tkaiser at Mon Jan 19, 2015 08:41
dreizehn replied at Mon Jan 19, 2015 08:28
right after the time is being set with the date command is being set back into the future


If ntpd is also running then it will reset the time to what it thinks is right. Have you tried to run ntpd in debug mode (providing one or more "-d" switches on the command line)? You might want to check with "ps auxww" how ntpd is normally running, then stop it and start it manually in debug mode: http://www.eecis.udel.edu/~mills/ntp/html/debug.html

Hi, sorry for answering so late
As you can see, ntp is not running anymore. I removed it

bananapi@bananapi /etc/rc2.d $ ps auxww|grep  ntp
bananapi 12637  0.0  0.0   4148   868 pts/0    S+   17:35   0:00 grep --color=auto ntp

so no ntp Daemon is able reset my time when I am setitng it wit hthe Date command, however I am sure, somehting is preventing my system to accept the correct time.

a1d3s  
on opensuse and kantotix in an old version this was an kernel bug that time runs away into future

Edited by dreizehn at Sat Jan 31, 2015 14:00

I am not Running opensuse. I am Running debian.  But i will install ntpd again and Check with Debug Mode

Hi, today, when I started apt-get upgrade, I noticed the following update:

Paketlisten werden gelesen... Fertig
Abhängigkeitsbaum wird aufgebaut.
Statusinformationen werden eingelesen.... Fertig
Die folgenden Pakete werden aktualisiert (Upgrade):
  ntpdate


After installing thiws update, I tried to run it with absolute the similar commands I used in the past but now with this result:

sudo ntpdate pool.ntp.org
8 Feb 16:19:09 ntpdate[8919]: step time server 46.4.32.135 offset -14.250216 sec

Fionally, with the new version of ntpdate, it looks like the problem is suddenly solved.

I am a little bit surprised, that no one had a similar problem and, a new Version of ntpdate solved my Time Sync Proble.

anyway....thanks :-)


Edited by dreizehn at Tue Feb 10, 2015 04:30

I want to add something more here:

It looks like the problem is solved, at least on my system.
Initially, the time was always 10 Minutes ahead and no command was able to correcty the time. I tried to set it with the date command, but the itme was immidiately set back into the future U used the ntpd, I used ntpdate etc...without success

A few days ago, 2 things happened:
A new NTP command was released: ntpdate 4.2.6p5@1.2349-o Thu Feb  5 21:34:27 UTC 2015
And I had to turn off my BananaPi for the first time.

Now since I updated ntpdate command (and booted my system again) , the time is now nearly correct. So I am not sure, if the shutdown (instead of reboot) solved something at the hardware clock (which does not exist) or the new NTPDATE command solved the problem.

The time will move 0.6 seconds per hour into the future so I added a cron that will correct the time every 30 Minutes form now on.
cheers Jan

You have to log in before you can reply Login | Sign Up

Points Rules