Bananian

[SOLVED] hostapd nl80211 doesn't exist

3 3678
AlterX  
Edited by AlterX at Wed Jan 21, 2015 06:12

Hello there,
I am trying to get hostapd up and run following this guide: http://raspberry-at-home.com/hotspot-wifi-access-point/, since it is exactly trying to configure same wifi chipset I have, but hostapd is alway telling me it doesn't know that driver. So I tried to recompile hostapd (enabling nl80211 feature), but I receive always message that driver doesn't exist.
I don't understand, bananian apparently is using 8188eu module for wifi dongle and even I put this in hostapd (rtl8188eu) it always tells me driver doesn't exist...

How can I get this worked?
Is there someone have ever used hostapd on banana pi?
Which wifi chipset is working well?

Thanks
Gianni
Hello, i have done this with my bananapro. It was hard to get this run..but it works

Attention, link ist in german. I hope it helps. My english isn't very well

http://frank-mankel.de/?p=401

Hi,

Please try to switch to rt8192cu.  The 8192cu wlan driver lacks some needed software apis for hostapd, iw and iwconfig. But that has been already mentioned in this forum.

AlterX  
Edited by AlterX at Wed Jan 21, 2015 06:15

Hi thanks,
I resolved in an easy way: downloading realtek source code of hostapd and recompiled. That's all (i think this code automatically use rtl8192cu):
just for those having same problem: http://www.jenssegers.be/blog/43 ... int-on-raspberry-pi

and file from realtek should be named like 0001-RTL8188C_8192C_USB_linux_v4.0.2_9000.20130911.zip

You have to log in before you can reply Login | Sign Up

Points Rules