Trouble

Multiple network issues

3 1671
treii28  
I seem to be having a number of networking issues and I am trying to determine if they are something inherent in the banana pi platform or something wrong with my device specifically. I already own two raspberry pi's (a B r3 and a B+ r2) and have never had any of these issues occur on either of them ever.

1) poor wired ethernet in general
First is just general crappy ethernet. This seems to occur the most often when rapid successive connections are being made such as when doing apt-get update or apt-get upgrade commands. Downloads freeze, some fail entirely and as near as I can tell, some get corrupted data back. (larger files almost always fail with Hash Sum Mismatch errors such as when updating the wolfram engine, headless-jvm or the sonic-pi core components). I have now tried four different OSs (Lebuntu, Bananian, and two variants of Raspbian) and the same problem(s) occur under all three

2) freezing using USB wireless adapter
I wanted to check to see if it might be a problem with the onboard wired ethernet adapter, so I tried a couple of different USB wifi adapters (all three of which I have regularly used on my other raspberry systems, again with zero difficulties). They seem to get recognized properly and the appropriate models load, but as soon as I try to connect to a wireless network, the entire system freezes and the only thing I have found that gets things going again is to entirely shut down and reboot. Often times it will then show the new network as though it worked, but it will not connect 'automatically' even when that checkbox is selected, and if I try to connect it manually, the system again freezes up. I have tried this again, with three different, Rpi tested and working wireless USB adapters and tried it on all four of the operating systems mentioned above. Same issue on all 12 variations.

3) freezing using Bluetooth
Similar to the above setting, I have tried to get the system tied to my IoGear multilink keyboard w/touchpad, and it behaves similar to the ethernet USB adapters. I have tried three different bluetooth adapters under all four OSs with similar results. It will start to pair, fail half the time before showing the pin. When it does generate a pin, it fails trying to pair about 4 out of 5 times. If it does finally show it as paired, it will not automatically connect. If it says it connects, either the bluetooth shuts itself off or the system freezes or the keyboard never does anything.

Again, at this point I am trying to figure out if these are known issues on Bpi's or something specific wrong with my unit. Has anyone else had these kinds of difficulties or know of any known issues that would cause these kind of headaches?

Tre
tkaiser  
Regarding the internal NIC: There were issues in the past but if you give a try again with a freshly burnt Bananian 15.01 then it has to work if the physical link (RJ jack, cable, switch/router connected to) is ok. I'm able to transfer many GBs with over 30 MB/sec (other host to BPi) or over 60 MB/sec (BPi to other host): http://forum.lemaker.org/thread-12167-1-1.html

Regarding wireless problems (applies to both Wi-Fi in the 2.4 Ghz band as well as bluetooth): Have you checked whether other 'senders' (eg cheap USB3 devices nearby) might interfere? The cross-checks you did with your RPis... did they happen at exactly the same location? That's important as well as necessary power supplied by the PSU in such situations. Bluetooth and wireless dongles automatically need more power when they're about to connect to something. So have you checked whether a) your PSU is sufficient and b) there are no voltage/current drops involved between PSU and BPi -- I've experienced that personally that a 'bad' Micro-USB cable led to 4.6V instead of 5V... with all sorts of strange consequences when USB peripherals are affected:



(from http://forum.lemaker.org/thread-8312-1-1.html)

treii28  
Hmmm. I switch to one of the Raspbian's just because I was still having fits. I suppose I could try going back. Use the lemaker image? (i went with www.bananapi.com before - my current raspbian is now from lemaker)

Just an example, I went to install caliber, 59195924 byte transfer. It failed integrity check the first 4 tries.

SW

treii28  
Edited by treii28 at Thu Jan 22, 2015 16:44

(oh, and as far as my PSU I have a 10A 5 port power-only hub to power my 3 pi's)

But as mentioned, I've tried a lot. I switch the ethernet cable and the hub port while testing the wired connection. I've tried 2 different wireless adapters and 3 different bluetooth adapters (all of which work just fine on either of my raspberries)

SW

You have to log in before you can reply Login | Sign Up

Points Rules