Bananian

Remove network cable then wlan unreachable - bananian 1501

7 2815
hi,

I used these instructions: http://oyox.de/882-wlan-auf-bananian-banana-pi-einrichten/
my: /etc/network/interfaces

auto lo
iface lo inet loopback

auto eth0

iface eth0 inet static
address 192.168.0.116
netmask 255.255.255.0
gateway 192.168.0.1

I added:

auto wlan0
#allow-hotplug wlan0
iface wlan0 inet static
address 192.168.0.121
netmask 255.255.255.0
gateway 192.168.0.1
wpa-ap-scan 1
wpa-scan-ssid 1
wpa-ssid "NAME-WLAN-NETZWERK"
wpa-psk "WLAN-KEY"

When I removed the cable: 192.168.0.121 is unreachable.
If I plug the cable in again: 192.168.0.121 is reachable.

Regards
tkaiser  
Can you check the routes please when both NICs are connected using 'netstat -rn' and post the output here?

tkaiser  
Or you might directly have a look at one possible solution (changing dynamically the default route when eth0 goes up/down): http://forum.lemaker.org/forum.p ... 7&fromuid=33332

tkaiser replied at Thu Jan 22, 2015 11:27
Can you check the routes please when both NICs are connected using 'netstat -rn' and post the output ...

Kernel-IP-Routentabelle
Ziel            Router          Genmask         Flags   MSS Fenster irtt Iface
0.0.0.0         192.168.0.1     0.0.0.0         UG        0 0          0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
192.168.0.0     0.0.0.0         255.255.255.0   U         0 0          0 wlan0

tkaiser  
Edited by tkaiser at Mon Jan 26, 2015 14:40
airzinho replied at Mon Jan 26, 2015 14:26
0.0.0.0         192.168.0.1     0.0.0.0         UG        0 0          0 eth0


As suggested in the other thread. Try to add the following two lines to the eth0 section in /etc/network/interfaces:
  1. pre-up if [ `ip route show|grep default|wc -l` -eq 1 ];then route del default gw 192.168.0.1 dev wlan0;fi
  2. post-down if [ `ip route show|grep wlan0|wc -l` -eq 1 ];then route add default gw 192.168.0.1 dev wlan0;fi
Copy the Code
And please report back and post the output of "netstat -rn" with both eth0 connected or not.

tkaiser replied at Thu Jan 22, 2015 13:24
Or you might directly have a look at one possible solution (changing dynamically the default route w ...

I tried the "solution" you suggested but it did not work for me.

On the other hand i found a thread where someone had a very similar problem:
https://debianforum.de/forum/viewtopic.php?f=30&t=141974

Maybe it is better to install a gui and let it do the network config?

tkaiser replied at Mon Jan 26, 2015 14:40
As suggested in the other thread. Try to add the following two lines to the eth0 section in /etc/n ...

What is right?
ifconfig shows the interface wlan0, scan for networks is ok, link up is ok saying something like: 10/half, 100/full, but then:

What is wrong?
wl_iw_set_wap: WLC_REASSOC failed (-22)
bcmsdh_sdmmc mmc1:0001:2: wlan0: (WE) Wireless Event too big (65305)

and in the end wlan0 is down.

I did some further testing:
1) I wiped /etc../interfaces clean, installed wicd-curses, but curses stumbled upon REASSOC. (Just to make sure that the problem was not my configuration.)
2) Then I bonded the interfaces (with eth0 the primary) and, when I unplugged the the ethernet cable, LOG said: trying to make wlan0 the active interface ... no success. (Just to make sure that unplugging is registered and proccessed.)
3) At last I disabled the ap..something driver/module and tried to set up an edimax on usb. What was right before was right now, but no establihed connection. (Just to make sure that the problem is not the driver/module.)

10 cm away a raspberry with raspian is having no problems with wifi. (I say that just to make sure that the problem is not the router.)

4) And I tried apt-get update&upgrade (bananian and not) as the last step.

And yes I googled "wl_iw_set_wap: WLC_REASSOC failed (-22)" and ... but I dont see a clear cause for the problem and a quick remedy.



shAGGie  
Edited by shAGGie at Sat Jun 6, 2015 12:48

@airzinho

same problem in my case, any positiv progress?

You have to log in before you can reply Login | Sign Up

Points Rules