Bananian

MATE desktop install guide

7 8324
mmax  
Edited by mmax at Mon Jan 26, 2015 13:38

Today I finally get MATE running on Bananian, its pretty fast.

Here is a quick guide:

I used root user account

Open resoures list
nano /etc/apt/sources.list

add following line:
deb http://http.debian.net/debian wheezy-backports main

After that:
apt-get update
apt-get upgrade


If you want to use LightDM login manager (can be disabled later) type:
apt-get -y install lightdm

Install Xorg:
apt-get install xorg

Restart
shutdown -r now

Now install MATE
apt-get install mate-desktop-environment-extras

and some additional utilities
apt-get install synaptic
apt-get install update-manager-gnome
apt-get install software-center


If you previously installed LightDM, enable it on boot-up
update-rc.d lightdm enable
If you want it disable later:
update-rc.d lightdm disable

If you have not installed LightDM or have disabled it, you can start MATE manually by:
startx /usr/bin/dbus-launch mate-session

or more convenient way, run once:
echo "exec mate-session" > ~/.xinitrc
this will create file .xintrc in user home directory and insert „exec mate-session“ into this new file

Then whenever you want to start MATE from console command line, just run
startx

Rate

1

View Rating Log

karlis  
Hello!
After executing apt-get install mate-desktop-environment-extras I have got error:
  1. The following packages have unmet dependencies:
  2. mate-desktop-environment-extras : Depends: mate-desktop-environment (= 1.8.0+9) but it is not going to be installed
  3. E: Unable to correct problems, you have held broken packages.
Copy the Code

Then I try to install mate-desktop-environment I got error
  1. The following packages have unmet dependencies:
  2. mate-desktop-environment-core : Depends: caja (>= 1.8.0) but it is not going to be installed
  3.                                  Depends: mate-panel (>= 1.8.0) but it is not going to be installed
  4.                                  Depends: mate-polkit (>= 1.8.0) but it is not going to be installed
  5.                                  Depends: gvfs-backends but it is not going to be installed
Copy the Code
and so on.
Finally I got error
  1. E: Package 'libpam-systemd' has no installation candidate
Copy the Code
My sources.list file:
  1. <div>deb http://ftp.de.debian.org/debian/ jessie main non-free contrib</div><div>deb-src http://ftp.de.debian.org/debian/ jessie main non-free contrib</div><div>
  2. </div><div>deb http://security.debian.org/ jessie/updates main contrib non-free</div><div>deb-src http://security.debian.org/ jessie/updates main contrib non-free</div><div>deb http://http.debian.net/debian wheezy-backports main</div>
Copy the Code


Any solutions?

nebkas  
Maybe you give 'apt-get -f install' a try. This could repair a broken install before. And then try again.

mmax  
Unfortunately it doesnt work with debian Jessie (bananian 15.08) anymore, just with older wheezy (bananian 15.04)

GNUser  
Since one is based on whezzy and the other one is based on jessie, could it be that we no longer need the backports? Jessie already has the MATE DE in repos I think.
Apart from that, can bananian work well with LXDE (installing from the repos with apt-get) ??

Hey could you maybe make a video showing how MATE behaves on the banana pi/pro/whatever you installed it in?

thanks!! nice tutorial

hoppy  
I have tried to install it from Jessie repos, same error as Karlis #2 above. Google did not help me with this error. Is there any other desktop available?

mmax  
Edited by mmax at Apr 16, 2016 03:01
hoppy replied at Apr 13, 2016 06:14
I have tried to install it from Jessie repos, same error as Karlis #2 above. Google did not help me ...

you can try XFCE

Simple with:

sudo apt-get install xfce4


Or with more stuff:
sudo apt-get install xorg xfce4 xfce4-goodies hicolor-icon-theme tango-icon-theme xfwm4-themes thunar-volman xfce4-power-manager volumeicon-alsa gnome-icon-theme-extras tumbler p7zip-full xarchiver dmz-cursor-theme gvfs

I had the same problem but solved it by using this command instead:

aptitude install mate-desktop-environment-extras

It will see the problem and offer a solution that recommends keeping the current version of several packages, which is listed as (not installed). Say no to that and it will change the solution to installing the stable versions or upgrading those packages. Say yes to that and it will install mate.

You have to log in before you can reply Login | Sign Up

Points Rules