Bananian

Can't setup wifi on Banana Pro with Bananian 15.01

2 9491
Nova  
Hi,

I can not get wifi working on my Banana Pro with Bananian 15.01. 15.01. should actually support the onboard wifi chip, but I couldn't also find a complete tutorial. I changed to hardware-layout to "Banana Pro" via bananian-config, I added "ap6210" to /etc/modules (which is mentioned here: https://www.bananian.org/hardware) and I configured /etc/network/interfaces (like here: http://www.canox.net/2015/01/banana-pro-wlan-einrichten/):
  1. auto wlan0
  2. allow-hotplug wlan0
  3. iface wlan0 inet dhcp
  4. wpa-ap-scan 1
  5. wpa-scan-ssid 1
  6. wpa-ssid "WLAN-NAME"
  7. wpa-psk "WLAN-KEY"
Copy the Code
After a reboot, wlan0 is found, ifconfig shows wlan0 and the ap6210 driver is loaded, but the DHCP discovery fails (nothing received). When I run "iwlist wlan 0 scan", no networks are displayed, but an error message: "Wireless Event too big".

Has someone a idea how this can get solved or what I could try to get it running?

Thank you in advance.

Regards,

Sven
Nova  
Solved! I just forgot to attach the long, ugly wifi antenna... The small edimax usb stick is somehow nicer...

spaxa  
Hi, i am trying to setup the wifi with the antenna on the BPro package (i have installed the Bananian-15.08).
I follow your procedure:

I modify the file /etc/modules - i added a new line with "ap6210"

I configured the file /etc/network/interfaces as follows (i want static ip address)
  1. auto wlan0
  2. allow-hotplug wlan0
  3. iface wlan0 inet static
  4. address 192.168.178.31
  5. netmask 255.255.255.0
  6. gateway 192.168.178.1
  7. wpa-ap-scan 1
  8. wpa-scan-ssid 1
  9. wpa-ssid "WLAN-NAME"
  10. wpa-psk "WLAN-KEY"
Copy the Code
but when when computer start i got an error message:

[ap6210] parse sdio_wifi_pro_used failed in script.fex
[ap6210] no wifi type selected, please ceck your config
[ap6210] failed to power up wifi chip

can you help me?
thanks

You have to log in before you can reply Login | Sign Up

Points Rules