Bananian

fsck on boot not working

2 2589
iwl  
Edited by iwl at Sun Feb 1, 2015 05:58

Hi Group,

tried to setup auto fsck on boot like on my raspi

sudo tune2fs -c 1 /dev/mmcblk0p2

~$ sudo tune2fs -l /dev/mmcblk0p2
...
Mount count:              71
Maximum mount count:      1
Last checked:             Wed Sep  3 20:58:34 2014
Check interval:           0 (<none>)

but does not work
no check on boot only a warning should be checked

sudo touch /forcefsck

doesn't help also, something wrong with the start scripts?

Realy would like to have sdcard checked, need to hard reset
or power is lost from time to time, just worked with the raspi...

May be I should rather use raspbian if fundamental stuff not working?
gbi  
Hi,

the fsck is usually handled in scripts which are in /etc/init.d, in standard Debian in checkroot.sh and checkfs.sh. The binaries which perform the real fsck's (like fsck.ext4 and so on) belong to the packages e2fsprogs or dosfstools (fsck.vfat) or ..

In my perception Bananian is standard Debian, but not the kernel and the bootloader. These are customized by nico. I can't access my BaPi in the moment, but I think looking for this scripts is a good idea. You can also check if the above mentioned packages are installed, or the fsck.* binaries are present on your BaPi.

good hunting

svakak  
Edited by svakak at Apr 08, 2016 03:22

By default Bananian does not have root mount entry in /etc/fstab and checkfs.sh script is looking for it and sets $rootcheck to zero if not found. If root mount point is not find or if fs_passno field is 0 fsck will not run.

Add something like this to your /etc/fstab and fsck on boot should work
/dev/mmcblk0p2  /       ext4    defaults,noatime        0       1

You have to log in before you can reply Login | Sign Up

Points Rules