How to mount large SD card partition as "/sdcard"

19 25522
deenbee  
Thank you now work perfect

Edited by Renebeek at Fri Nov 14, 2014 04:54

Thanks for this it works fine.
But my hdd don't
Can i make à change for this?

dlanor  
Similar editing can modify how the HDD is mounted, but first you need to be sure that it is the mounting that fails, and not something else.
For me the original SATA mounting method works fine, so I suspect that there's some other problem which prevents it from working for you.

One common mistake is how to connect the PSU:
As you know there are two micro-USB connectors on the BPi circuit board, either one of which can be used to power the BPi itself.
But it is only one of those which will also allow a connected SATA drive to work properly.
And that is of course the micro-USB connector positioned between the SATA power connector and the SATA data connector on the board.

Some people claim that it's necessary to provide power to both connectors, but that's a misunderstanding.
That's only necessary if using the cheap kind of phone-charger PSUs, which supply a current limited to 1A or less.
As long as the PSU can deliver sufficient current, you only have to use one of the BPi power connectors,
and for using the SATA drive the required BPi PSU connector is the one between the SATA power and data connectors.

I hope this helps you get your HDD to work with your BPi.

Best regards: dlanor

vinbig  
Edited by vinbig at Sat Nov 15, 2014 13:07

Hello;
i installed android4.4 Beta 1 at this link:
http://www.bananapi.com/index.php/download?layout=edit&id=29

But I didn't find the file vold.fstab in etc folder.
Can you help me?
Thanks in advance

best regards
Vincent

dlanor  
The Android 4.4 image is not produced by anyone connected with this site, so the amount of help you can get for it here is limited.
You'd get much better support here for the Android 4.2 images, which are developed and supported by forum members.

The Android 4.4 image differs greatly from the Android 4.2 images in some negative ways, including not being rooted.
This means that there are many folders of the root directory of this Android 4.4, where the user can't even see the contents.
(And that includes subfolders, which you then can't even see the existence of.)

The few distinct advantages that the Android 4.4 image does have, such as better support for external keyboards and some other things, these are rapidly being added to the latest modified Android 4.2 images too (now compatible to the logitech K400 keyboards etc).

I tried out that Android 4.4 image myself a while back, but gave it up as hopeless when I discovered the lack of root access.
Without root access there's not much a serious user can do at system level, so for me that was a 'dealbreaker'.

Best regards: dlanor

ChrisP  
Edited by ChrisP at Tue Nov 18, 2014 17:49
vinbig replied at Sat Nov 15, 2014 18:28
Hello;
i installed android4.4 Beta 1 at this link:
http://www.bananapi.com/index.php/download?layout ...


The structure of filesystem mount config changed after Android 4.2.2

Have a look here: http://source.android.com/devices/tech/storage/config.html

Wieczor  
Thanks for this it didnt work with USB hdd but when I connected it to SATA and changed entry it works like charm

vinbig  
thanks a lot for your answer, I will follow your advice ;-)

Alfm  
Edited by Alfm at Tue Apr 28, 2015 21:40
vinbig replied at Mon Nov 24, 2014 04:27
thanks a lot for your answer, I will follow your advice ;-)


thanks for this solution. When trying to download direct from internet using Bit-torrents I have been unsuccessful in having the file directed to my internal SATA drive. It keeps telling me that it cannot write to specified directory.
Do you think you tutorial will solve that problem..I have tried many "Fixes" that have not worked.

I really appreciate all the good work "dlanor" is doing and I will follow your posts with keen interest.
I also would hope that the imige can be changed to solve many of these types of issues. Thanks Alf








mike57  
Hey dlanor,

thank you for your efforts on behalf of us all.

You have to log in before you can reply Login | Sign Up

Points Rules