Setting up wlan0 as an access point in BPI-R1

35 30848

i set up an Access Point following the instructions and its working, thank you for this manual .
But after some tests with InSSider tool, i noticed, that the Signal strength is only getting better from antenna port ANT2 on the BPI-R1. It doesn't matter, if there is an Antenna connected to ANT1. Does anyone else have the same problem? i also added my hostapd.conf, if that can help


  1. ctrl_interface=/var/run/hostapd
  2. ctrl_interface_group=0
  3. macaddr_acl=0
  4. auth_algs=3
  5. ignore_broadcast_ssid=0

  6. # 802.11n related stuff
  7. ieee80211n=1
  8. noscan=1
  9. ht_capab=[HT40+][SHORT-GI-20][SHORT-GI-40]

  10. #WPA2 settings
  11. wpa=2
  12. wpa_key_mgmt=WPA-PSK
  13. wpa_pairwise=TKIP
  14. rsn_pairwise=CCMP

  16. wpa_passphrase=ICanHasBananaz

  17. # Most modern wireless drivers in the kernel need driver=nl80211
  18. #driver=nl80211
  19. driver=rtl871xdrv
  20. max_num_sta=8
  21. beacon_int=100
  22. wme_enabled=1
  23. wpa_group_rekey=86400
  24. device_name=RTL8192CU
  25. manufacturer=Realtek

  26. # set proper interface
  27. interface=wlan0
  28. bridge=lanbr0
  29. hw_mode=g
  30. # best channels are 1 6 11 14 (scan networks first to find which slot is free)
  31. channel=6
  32. # this is the network name
  33. ssid=BPI-R1
Copy the Code

Hello patrole

I never thought about that there could be a difference on my BPi-R1, so I just tested it now

And you are right, I noticed a difference between the ports too, but only around 25dBm,

I don't know where this come from, but maybe its connected to the driver version.

thanks for the reply nebkas

First i tested it with the standard 8192cu v3.3.2 driver with the modified "hostapd-rtl" from bananian.
Then, with the newest RTL driver v4.0.2 together with their hostapd-0.8 from Realtek. Both had the same result. It's like the chip can only use one Antenna

Maybe you check the antenna cable connection on the board. I remember it was really hard to put the plugs right together on the board, so that this worked finally well after the second or third try.

I'm using the hostapd-rtl package with the 4.0.2_9 driver from

It works ok for me, but there are tonns of:

Oct  6 14:38:39 nebkas kernel: [219900.390529] issue_nulldata(wlan0) to 1c:7b:21:5c:4b:1d, ch:11, 1/1 in 20 ms
Oct  6 14:38:39 nebkas kernel: [219900.394713] ack check for asoc expire, keep_alive_trycnt=1

messages into the syslog

I checked the cable connection on the board and used different antenna cables. i even used another bpi-r1 board to rule a faulty board out.

i had the same result with the 4.0.2_9 driver from dz0ny

Did anyone testet this with another image? Armbian or OpenWRT?

You have to log in before you can reply Login | Sign Up

Points Rules