Other OS

wlan0 not working in raspbianPRO

9 3267
Dliloch  
Edited by Dliloch at Thu Feb 5, 2015 14:19

Hello,
I've installed the Raspbian for bananapiPRO 1412 .. the eth0 is fine.. but I can't get wlan0 to work ..
the gui says could not get status from wpa_supplicant ...
if I try sudo ifup wlan0 I get this message:
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
failed to connect to wpa_supplicant - wpa_cntrl_open: No such file or directory
wpa_supplicatn: /spin/wpa_cli daemon failed to start
run-parts: /etc.network if-up.d/wpasupplicant exited with return code 1

if I do ifconfig .. I do not see wlan0 .. I see eth0, lo and tunl0

found it .. on another post: tony_zhang
says:
sudo modprobe ap6210
then to make permanent:
gwaihir says:
sudo nano /etc/modules
Add "ap6210" at the end of file
that worked ..
so my question now is if you have the hardware onboard.. why not include this in the PRO raspbian distro??
Answer to your question:
Someone may want to use wifi as its AP mode, so in that case we need sudo modprobe ap6210 op_mode=2. You can refer to this: http://wiki.lemaker.org/WiFi#WiFi_AP_mode

We can not limit everyone how to use WiFi.

Dliloch  
tony_zhang replied at Thu Feb 5, 2015 20:09
Answer to your question:
Someone may want to use wifi as its AP mode, so in that case we need sudo  ...

thanks for the reply tony ... you might want to include this option in bpi-update ... just a thought ...

melyz  
With describe of this working problem on here you did very good work from others can also get help on it. CV writing is very important for us and resume services review is very helpful for hiring of professional writers.

You have to log in before you can reply Login | Sign Up

Points Rules