Discussion

wpa_supplicant not working on banana pro

9 4388
Hi,

i'm sorry for asking that newbie question but i'm working on it for hours but it still doesn't work :-(

i want to use onboard-wifi on my banana pi pro in different networks, so i tried to setup wpa_supplicant. But everytime i try to use it, i get an error:
  1. wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
  2. run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Copy the Code
if i setup the wifi directly in /etc/network/interfaces i works perfect but with wpa_supplicant... nothing! Here are my settings:

/etc/network/interfaces
  1. auto lo
  2. auto wlan0

  3. iface lo inet loopback
  4. iface eth0 inet dhcp

  5. allow-hotplug wlan0
  6. iface wlan0 inet dhcp

  7. wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

  8. iface default inet dhcp
Copy the Code
/etc/wpa_supplicant/wpa_supplicant.conf
  1. ctrl_interface=DIR=//var/run/wpa_supplicant
  2. GROUP=netdev
  3. updaet_config=1

  4. network={
  5.         ssid="WLAN"
  6.         scan_ssid=1
  7.         proto=RSN
  8.         key_mgmt=WPA-PSK
  9.         pairwise=CCMP
  10.         group=TKIP CCMP
  11.         psk="WLAN-KEY"
  12. }
Copy the Code
best regards, Stephan
Hi !

In your wpa_supplicant.conf :
updaet_config=1

should be:
update_config=1

Edited by balli1187 at Sun Feb 15, 2015 03:25
HWL_Stouf replied at Sat Feb 14, 2015 09:27
Hi !

In your wpa_supplicant.conf :


Hi,

what a dumb typo... but it's just here in the forum! I checked it in the file and it is correct there, so it can't be the reason. Any other suggestions?

Another typo :
  1. ctrl_interface=DIR=//var/run/wpa_supplicant
  2. GROUP=netdev
Copy the Code
should be :
  1. ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
Copy the Code
(on the same line, and a "/" removed)

The PSK line also seems strange, and those parameters are not needed.
If your ESSID is "WLAN" and PSK is "WLAN-KEY", execute the following command :
  1. wpa_passphrase WLAN WLAN-KEY
Copy the Code
It returns :
network={
        ssid="WLAN"
        #psk="WLAN-KEY"
        psk=a08b4a3ca85cedde096c96a6b3528683135f66a3280b2b702a46b8db5be25a2f
}

This is the parameters you have to put in your wpa_supplicant file.

HWL_Stouf replied at Mon Feb 16, 2015 09:33
Another typo :should be on the same line, and a "/" removed)

The PSK line also seems strange, and ...

weahhhhh.. another typo. But same like the first one. only in forum, not on the Banana.

I edited the psk-line but still get the same error. I don't think it is a problem with the settings in wpa_supplicant.conf because the error message refers to the daemon. Do i have to setup something in another file before wpa_supplicant works?

I just tried to install wpa_supplicant (was already on my raspbian-image) and added the the lines in /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf

Best Regards, Stephan

hawhill  
Try running wpa_supplicant without wrapper script with debug output enabled and see what it says.

T.S.  
One other option is installing "wicd-curses". That worked fine in my case.

Sorry for the long break... My Job is spoiling my hobbies

I tried running wpa_supplicant with debug output like hawhill said. I returns a invalid command in line 2 of wpa_supplicant.conf ("GROUP=netdev"). After deleting this line, i didn't get error reports in debug mode. However wpa_supplicant isn't working but i think i broke another file while trying to solve the problem

Now i'm using bananian instead of raspbian and it works from the off with wpa_supplicant. I want to give bananian a try and it was just the right time to do that.

Thanks everybody for help!

It looks like i've got the same problem after messing around with the auto-config file from the OMV image (i've set up wake on lan in there, but since then i didnt manage to get wpa_supplicant working again).

hnsncxy  
You can refer to the WiKi at http://wiki.lemaker.org/WiFi

You have to log in before you can reply Login | Sign Up

Points Rules