Easiest way to compile 3.17/3.19 kernel

87 19218
Edited by igorpec at Thu May 7, 2015 18:02
I ran a build and the system crashed as descriped in the last post.  I modified the common.sh to remove the copy so i uses the same .config file.  I got the following errors but it finished ok.  Are these 4 error expected or do I need to address them?

The first one matters most. It tells me that kernel compilation is failing.

Run script with KERNEL_ONLY="yes" that you build only kernel. If it works well with my config than you made some problem.

BTW. Currently Uboot source is broken. You are ok because you have one cached but otherwise this would break the whole thing. Use commit v2015.04 or wait for my script updates. There are many but still testing. I hope I'll commit later this evening.

The last 2 builds I did, actually build and I even show my usb audio device.  I'm attempting one more now with a few more kernel tweeks.

The problem I have been having is that win32diskimager erroring, even blue screen of death on windows.  I am now using dd from the linux system and is working well (I cannot get imagewriter.exe to work for me.

I'll update later if all is working for me or not.

The last build I included the usb audio drivers.  That seems to be working.  

Couple questions.  I cannot seem to figure out how to set screen resolution.  1024x768 is the only option.   Searches of the internet find many ways but either don't work or don't apply.  I show in the bananapi.fex and bananapipro.fex files "ctp_screen_max_x = 1024" and "ctp_screen_max_y = 600".  Is this releated?  Igor, do you know?

One more question for you Igor.  Almost every time I reboot it goes through first run and so boots twice, but not every time.  What triggers this to run or not run?

Edited by tkaiser at Fri May 8, 2015 07:58
markwinger replied at Fri May 8, 2015 07:51
"ctp_screen_max_x = 1024" and "ctp_screen_max_y = 600"

Have a look at Igor's FAQ, edit boot.cmd so that it contains "disp.screen0_output_mode=EDID:1024x600p60", recreate boot.scr as described by Igor and give it a try.

I'm currently playing around with a 1024x600 LCD display connected via HDMI and while it worked at one time now I'm running into synchronisation issues with the LCD's signalboard.

Is the resolution in the uEnv.txt file?  Internet searches say 'boot' but I don't see it there. "find . | grep uEnv.txt" from '/' does not find it.  Where is this file located in the image?  
The source  lib/config/uEnv.bananapi says disp.screen0_output_mode=EDID:1280x720p60 but the desktop indicates the the resolution is 1024x768(not sure what it actually is).

markwinger replied at Fri May 8, 2015 07:59
Is the resolution in the uEnv.txt file?  Internet searches say 'boot' but I don't see it there. "fin ...

It's described in his FAQ:

screen resolution – change it + reboot:

nano /boot/boot.cmd
mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr

And there you adjust disp.screen0_output_mode. I also made some tests using fbset ("apt-get install fbset") and added the following to /etc/fb.modes
  1. mode "1024x600-75"
  2.     # D: 65.003 MHz, H: 48.365 kHz, V: 75.807 Hz
  3.     geometry 1024 600 1024 600 32
  4.     timings 15384 160 24 29 3 136 6
  5.     rgba 8/16,8/8,8/0,8/24
  6. endmode
Copy the Code
and put a
  1. fbset "1024x600-75"
Copy the Code
at the end of /etc/rc.local. But this leads to synchronisation problems and i don't get which timing parameters i would need for 1024x600 @ 60Hz. Note: I'm only talking about 1024x600 via HDMI

Edited by igorpec at Fri May 8, 2015 19:49

I just commit build script.

Many changes, FAQ changed, Ubuntu / Jessie problems fixed.

I made many many test runs and remove many tiny bugs ;)

Detail info, images, kernel, ... soon

I have been unsuccessful and changing the resolution by modifying boot.cmd and mkimage.  Native resolution of the monitor is 1680x1080 (VGA with hdmi converter).  When I reboot the console says:EDIE invalid mode setting to 1024x768.  If I cat /sys/class/graphics/fb0/modes, it shows only one mode U:1024x769p-0.

Everything indicates 1024x768 is the only allowed mode.  I tried to change it with fbset but no success.  What am I missing?

P.S. I am building a new kernel now using the new script and we'll see how it goes.

Edited by igorpec at Sat May 9, 2015 17:55
markwinger replied at Sat May 9, 2015 16:07
I have been unsuccessful and changing the resolution by modifying boot.cmd and mkimage.  Native res ...

Have you try with leaving EDID out?
  1. nano /boot/boot.cmd

  2. # example:
  3. # change example from
  4. # disp.screen0_output_mode=1920x1080p60
  5. # to
  6. # disp.screen0_output_mode=1280x720p60

  7. mkimage -C none -A arm -T script -d /boot/boot.cmd /boot/boot.scr  
Copy the Code

There is no EDID on the resolution arguement, but there is on the audio.  Here is my command line:

setenv bootargs console=tty1 root=/dev/mmcblk0p1 rootwait rootfstype=ext4 sunxi_
ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_mali_mem_reserve sunxi_fb_mem_
reserve=16 hdmi.audio=EDID:0 disp.screen0_output_mode=1680x1080p60 panic=10 cons
oleblank=0 enforcing=0 loglevel=1

Are you saying remove the EDID:0 from the hdmi.audio= argument?

You have to log in before you can reply Login | Sign Up

Points Rules