Easiest way to compile 3.17/3.19 kernel

87 19394
I removed the EDID from the audio argument.  No change.  I removed the hdmi.audio argument completely, still no change.

I tred removing EDID formt he hdmi.audio argument.  No.  Tried removing the hdmi.audio argument altogether, still no go.

Edited by tkaiser at Sun May 10, 2015 06:47
markwinger replied at Sat May 9, 2015 13:57
Native resolution of the monitor is 1680x1080 (VGA with hdmi converter)

Ah, now I understand. You don't want 1024x600 but 1680x1080 instead. The problem is: It's not supported at boot. Only these modes are currently hardcoded into the sunxi HDMI driver:
  1. Supported HDMI modes:
  2. 2       480p
  3. 4       720p 50Hz
  4. 5       720p 60Hz
  5. 6       1080i 50 Hz
  6. 7       1080i 60 Hz
  7. 8       1080p 24 Hz
  8. 9       1080p 50 Hz
  9. 10      1080p 60 Hz
  10. 23      1080p 24 Hz 3D
  11. 24      720p 50 Hz 3D
  12. 25      720p 60 Hz 3D
Copy the Code
Just realized that today. I try to use 1024x600 via HDMI and used "disp.screen0_output_mode=1024x600p60" in boot.cmd. But that was ignored and replaced with 720p@50Hz. And while my custom entry in /etc/fb.modes for 1024x600@75Hz seems to work the display's signal board had sync troubles most of the times.

Now i stumbled accross http://sourceforge.net/projects/umc/ and tried to create an entry for 1024x600@60Hz:
  1. root@lamobo:~# /usr/local/src/umc-0.2/src/umc 1024 600 60 --fbset

  2. # 1024x600x60.00 @ 37.500kHz
  3. mode "1024x600x60.00"
  4.     geometry 1024 600 1024 600 16
  5.     timings 20325 144 40 17 4 104 4
  6.     hsync low
  7.     vsync high
  8. endmode
Copy the Code
But these values didn't worked and this is with what I ended up with after playing around with some of the values:
  1. root@lamobo:~# fbset -i

  2. mode "1024x600-60"
  3.     # D: 49.200 MHz, H: 37.500 kHz, V: 60.001 Hz
  4.     geometry 1024 600 1024 1200 32
  5.     timings 20325 144 40 17 4 104 4
  6.     vsync high
  7.     accel true
  8.     rgba 8/16,8/8,8/0,8/24
  9. endmode

  10. Frame buffer device information:
  11.     Name        :
  12.     Address     : 0x49001000
  13.     Size        : 7372800
  14.     Type        : PACKED PIXELS
  15.     Visual      : TRUECOLOR
  16.     XPanStep    : 1
  17.     YPanStep    : 1
  18.     YWrapStep   : 0
  19.     LineLength  : 4096
  20.     Accelerator : No
Copy the Code
Now the display works flawlessly like with any Raspberry Pi. For your resolution umc gives the following values:
  1. # 1680x1080x60.00 @ 67.260kHz
  2. mode "1680x1080x60.00"
  3.     geometry 1680 1080 1680 1080 16
  4.     timings 6590 288 104 33 4 184 4
  5.     hsync low
  6.     vsync high
  7. endmode
Copy the Code
I would better try with
  1. mode "1680x1080-60"
  2.     # D: 49.200 MHz, H: 37.500 kHz, V: 60.001 Hz
  3.     geometry 1680 1080 1680 1080 32
  4.     timings 6590 288 104 33 4 184 4
  5.     vsync high
  6.     accel true
  7.     rgba 8/16,8/8,8/0,8/24
  8. endmode
Copy the Code
and then put »fbset "1680x1080-60"« in /etc/rc.local.

Thanks, I'll see if I can get that to  work tonight.

I want to thank you guys.  This current kernel (terminal resolution pending)  is working great.  I have succeeded in getting the low latency networked audio working (I still have work to do). The proof off concept on the banana-pro had passed with flying colors.

I would also like to do this on the odroid-c1.  Have you done any work with this platform?  (I would use the raspberry B+ rev 2 but I need gig Ethernet for this) You currently support quit a few platforms with your kernel build and it would be really cool if I could get the odroid-c1 and the banana on the same builds.

Thanks.  Mark

Still not luck with the resolution.  The first thing printed at boot time is a message about the invalid crc, using default environment.   Is this related some how?


It also prints "HDMI connected: EDID: Invalid EDID data" at boot time.


Cpu frequency.  I have set min and max cpu speed to max as describe in the faq.  I set MAX_SPEED="1010000" and MIN_SPEED="1010000".  But how do I confirm this worked?

I loaded sysbench and ran cpu tests and compared with review posted by others and I show 179 but this report http://hardware-libre.fr/2014/06 ... nana-hardware-duel/ shows 148.   


at my system:
current policy: frequency should be within 480 MHz and 960 MHz.
480 MHz:83.46% and 960 MHz:15.01% and some small parts in between.

markwinger replied at Mon May 11, 2015 07:53
Cpu frequency.  I have set min and max cpu speed to max as describe in the faq.  I set MAX_SPEED="10 ...

If you're after performance you might run into thermal issues. I would search the forum for "/sys/devices/system/cpu/cpu0/cpufreq", "/sys/devices/platform/sunxi-i2c.0/i2c-0/0-0034/temp1_input" or even "bpi-monitor.tgz" to get a clue how to readout the actual CPU frequency as well as the PMU's and SoC's temperature.

BTW: Forget about the one year old hardware-libre test regarding performance. The results date back from a time when only really crappy distros with wrong settings were available for Banana Pi. I believe the LeMaker guys combined a Raspbian image with Allwinner's sunxi Linux kernel and forgot to adjust relevant stuff (eg. the CPU governor settings. The problem is outlined here in detail).

BTW: Adjusting CPU frequency works in steps of 48MHz and will always be rounded down (in your case to 1008 MHz but unless you also take care of the CPU governor in question every frequency setting has no meaning. Same applies at the moment to mainline kernel since the cpufreq stuff isn't working there. And since you're still posting in mainline kernel thread this might be a problem as well?)

I have done the searches for cpufreq, but my system does not contain a /sys/devices/system/cpu/cpu0/cpufreq, or /sys/devices/platform/sunxi-i2c.0/i2c-0/0-0034.

It difficult when searching for answers and 90% say to look at files that do not even exist on the system.  I am aware of the temperature issue.  The standard for highperformance audio is to use the performance governor, but it appears the cpufreq is completely disabled.
The results of cpufreq-info is what got me looking into this:

root@bananapi:/etc/init.d# cpufreq-info
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  no or unknown cpufreq driver is active on this CPU
  maximum transition latency: 0.00 ms.
analyzing CPU 1:
  no or unknown cpufreq driver is active on this CPU
  maximum transition latency: 0.00 ms.

You have to log in before you can reply Login | Sign Up

Points Rules