Bananian

Setup A Wireless Device?

7 2691
Roy360  
Edited by Roy360 at Sat Feb 28, 2015 22:33

I want to start a project with my Banana Pi.

But first, I need to connect to it wirelessly. I currently have it on an ethernet connection, but how do I connect it to my wireless network?

I'm using a standard TP LINK 150N Adapter.

I can scan for wireless networks, and I found mine.

I went into : /etc/network/interfaces and added the following lines to it:

auto eth0
auto wlan0

iface eth0 int dhcp
iface wlan0 inet dhcp

        wireless-essid [ASUS]
        wireless-mode [MASTER]

What now? How do I make it automatically connect to the wireless? I won't always have a wired connection

Roy360  
No my issue isn't with the driver.

Plus, since I can scan, I"m sure the driver is already installed.

Going to try a fresh install with this tutorial:http://www.blackmoreops.com/2014 ... mand-line-in-linux/

Once I get this running, I need to figure out how to get Netbeans to compile on my PI. Aswell as find the includes file for this board.  

atjr  
Edited by atjr at Fri Feb 20, 2015 15:00

are you can ifup wlan0, and what result?

Roy360  
atjr replied at Fri Feb 20, 2015 01:59
are you can ifup wlan0, and what result?

It says
n180211 not found.


atjr  
Edited by atjr at Sat Feb 21, 2015 08:58

let  try disconnect - unplug eth0  first, and make sure wlan0 it's present. then

/etc/init.d/networking  restart

and let see what interface status
$ ifconfig   
or
$ ip addr show

Matuka  
Hi,
I try to ask here also, it is a banana pi routerboard, not an external device, i have problem with the internal device.

I tried the this configuration and works well. But, the wifi signal strength is very weak:
  1. IEEE 802.11bgn  ESSID:"curacaong"  Nickname:"<WIFI@REALTEK>"
  2.           Mode:Master  Frequency:2.432 GHz  Access Point: AC:A2:13:5C:AC:81   
  3.           Bit Rate:300 Mb/s   Sensitivity:0/0  
  4.           Retry:off   RTS thr:off   Fragment thr:off
  5.           Encryption key:off
  6.           Power Management:off
  7.           Link Quality=90/100  Signal level=-67 dBm  Noise level=0 dBm
  8.           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
  9.           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
  10. Copy the Code
Copy the Code
I tried to increase the txpower, but it says:
  1. Error for wireless request "Set Tx Power" (8B26) :
  2. SET failed on device wlan0 ; Invalid argument.
Copy the Code
Anybody has same experience? Any suggestion to me?

Thanks in advanced.

Roy360  
Edited by Roy360 at Sat Feb 28, 2015 23:58

I've re-installed Bananian and installed XDRP.

What should I do from the beginning?

You have to log in before you can reply Login | Sign Up

Points Rules