Dead BPro - red led of death - no boot

12 4430
Edited by jakubs11 at Sat Mar 7, 2015 02:00


Some time ago I wrote about my little project with BananaPro LINK

Well, some time ago I went on a 3-day trip and when returned I realized that my BPro isn't working. i tried to restart it but the only thing i could get from it was a constantly on red led.

I searched though the forum and found out about the issues with PSU, PSU cables, microSD cards, microSD adapters so i tried:
2 different PSU:
- 5V 2A from a raspberry shop with built-in cable
- 5v 2.1A wall charger for OnePlus One with 2 different cables

3 different microSD cards:
- class10 16GB
- class10 8GB
- class4 4GB

3 different OS's form lemaker download section:
- Raspbian (which i have been using for a quite some time)
- Bananian
- Lubuntu

I 'burned' the images on microSD cards using:
- windows + Win32DiskImager + built-in microSD reader
- windows + Win32DiskImager + built-in SD reader with adapter (3 different computers)
- windows + Win32DiskImager + microSD-to-USB adapter (3 different computers)
- linux mint + dd + built-in microSD reader
- linux mint + dd + built-in SD reader with adapter (2 different computers)
- linux mint + dd + microSD-to-USB adapter (2 different computers)

No matter what I did, only the red LED was turning on when power was plugged. *yes, the right mircoUSB port, not OTA*

So, not seeing other options I ordered PL-2303HX with a set of cables.

This is just to comfirm validity of my USB-to-TTL adapter

A picture of by USB-to-TTL adapter

And a dead BananaPro powered and conected to serial:

and this is the output when BPro power cabel is plugged in, different USB ports (2.0 and 3.0), different PSUs:

just a check if I connected the cables right:

There is no hdmi output, no green/blue LED blinking, SSH fails, ethernet LEDs doesnt blink when cable connected, no reaction to plugging in USB peripherals.
I'd like to point out that I have been using BPro for over a month, i burned multiple images on microSD cards, i used Banana both with screen+mouse+keyboard and SSH-ing to it.
I had the USB-to-TTL adapter checked by a friend for other uses - it's valid.
I don't know what else can i try. Any suggestions?
If the USB-to-TTL adapter work on another Banana Pro, but not work on yours, the only problem I can think is that the Banana Pro broken due some reasons.
If possible, you'd better consult the sellers for exchange, or please PM me your email, I may ask somebody to help you.

Edited by jakubs11 at Sat Mar 7, 2015 11:17

Unfortunately I do not have access to another Banana Pro. It works with my friend's arduino (?), I think...
Anyway, does it matter if I use PL2303HX (that i own) instead of PL2303TA (the one that is in the lemaker wiki)?

I can not sure if the PL2303HX is suitable for Banana Pro. The ttl voltage is 3.3V on Banana Pro, but most arduino is 5V

Ok, I already contacted AliExpress seller to consult for exchange. I wll also try to aquire something like: eBay_link and try again. For all i have read and all I have seen it seems like my DDR or processor got fired :/

Edited by jakubs11 at Thu Mar 12, 2015 12:02

I tested my BPro with PL2303TA and the output is


Do I have any other options than getting a new Banana?

Another question I'd like to ask: it a common issue to get your BananaPro RAM burned?

Anybody knows? pretty please

Try reflowing it (youtube has many diys)

I've got the same error:
U-Boot SPL 2014.04-10733-gbb5691c (Dec 18 2014 - 12:54:35)                                         
Board: BananaPro                                                                                   
DRAM: 0 MiB                                                                 
### ERROR ### Please RESET the board ###

Anyone solved this problem?

I have the exact same problem as above stated by the other guys here: after 2 months of use only the red led is lit nothing else.I tried numerous other cards and power adapters to no avail  untill I also tested my BPRO with the  USB-to-TTL adapter in order to investigate what's going on and got the same error result as above.

It appears  the mem failed: DRAM 0 MB which means they were either poorly soldered/defective  or burnt in use   
Please note that I never tried any OC of any kind on it

Now I see here 2 options: one is RMA but good luck with that when you buy from chinese  orr take the hard way of trying to reflow/replace the DRAM with a hot air station. I personally will take the hard way and try the reflow,but just in case it will still not work  does anybody know where to order those 2 chips of 512 RAM each?

In conclusion I say its 50/50 a bad design-software- for BananaPro or poorly built but either way, it is a  bad name for Lemaker as I saw many people are already complaining. It's unacceptable for the BPro to fail after 2 months of regular use.

You have to log in before you can reply Login | Sign Up

Points Rules