how to switch the default audio device (in Android)

39 11767
Bram  
Hi,

Sorry for my late reply... I ended up buying a USB DAC en everything works perfect now! It still seems that there is some kind of signal/current to the jack, even though I disabled all possible tv out settings in the config file.

Now it would be nice to be able to set my default audio to AUDIO_USB0. I Tried to change the settings in audio_policy.conf but either I end up seeing no outputs at all or even when I change it to USB0 it hops back to the AUDIO_CODEC... Any clue how to fix this?

liab  
Bram replied at Fri May 29, 2015 16:21
Hi,

Sorry for my late reply... I ended up buying a USB DAC en everything works perfect now! It stil ...

You see this in the Android Audio Settings:
AUDIO_CODEC
AUDIO_HDMI
AUDIO_SPDIF
AUDIO_USB0

If yes, it's not a great thing to adjust my Aud/WiFi app.

Bram  
liab replied at Sat May 30, 2015 16:24
You see this in the Android Audio Settings:
AUDIO_CODEC
AUDIO_HDMI

Hi,

My options are AUDIO_CODEC, HDMI and AUDIO_USB0, can you point me in the right direction then? Where can I find yor app?

Thanks!

liab  
Bram replied at Mon Jun 1, 2015 01:27
Hi,

My options are AUDIO_CODEC, HDMI and AUDIO_USB0, can you point me in the right direction the ...

My app is in all my images, but not with AUDIO_USB0. If I have a little bit time, I shall make a version with AUDIO_USB0.

Bram  
Fantastic, thanx!

liab  
Bram replied at Mon Jun 1, 2015 09:04
Fantastic, thanx!

Please read the readme and test the app:
https://www.dropbox.com/s/9gsreu4f1ok5njo/testapp.tar.gz?dl=0

Bram  
liab replied at Mon Jun 1, 2015 15:45
Please read the readme and test the app:
https://www.dropbox.com/s/9gsreu4f1ok5njo/testapp.tar.gz? ...

Hi Liab,

It's almost working. Following your instructions sets the default audio to audio_codec, but that is not corresponding with the audio_usb0. Starting the app from the command line with am start -a android.intent.action.MAIN -n com.liab.audiomanager/.MainActivity3 -e param a
So a instead of c it gets the usb audio working. I tried to change the lines in the audio file I've placed in system/xbin, but it still does not autostart.

The audio file is the only one starting the app right?

liab  
Bram replied at Tue Jun 2, 2015 02:23
Hi Liab,

It's almost working. Following your instructions sets the default audio to audio_codec,  ...

The audio file is the only one starting the app right?
That's right.
Please download it new. A little bit more beauty and a better readme. Is USB0 the only possibillity or is USB1 a option too?

Bram  
liab replied at Tue Jun 2, 2015 08:36
The audio file is the only one starting the app right?
That's right.
Please download it new. A lit ...

Hi Liab,

Thank you very very much!!! It's working like a charm now! USB1 is an option but absolutely not necessary, USB0 is more than good enough for me. I guess I should have made the audio file executable in the previous version as well right? But you're absolutely right this is with a lot more beauty...

Thank you again!

Cheers,

Bram

liab  
Bram replied at Tue Jun 2, 2015 09:49
Hi Liab,

Thank you very very much!!! It's working like a charm now! USB1 is an option but absolut ...

I'm really pleased.

The last half hour I made small changes, not visible. The mainactivity is also startable with the same parameters like the mainactivity3.

You have to log in before you can reply Login | Sign Up

Points Rules