Bananian

Build Error

3 2366
s33w0lf  
Edited by s33w0lf at Wed Mar 25, 2015 14:53

Hi guys,
I have the following problem:
I try to build a modified version of hostapd. It should ignore bss neighbor check. But this is not the problem.
I get this error:

  1. ~/hostap/hostapd# make
  2. cc: error trying to exec '/usr/lib/gcc/arm-linux-gnueabihf/4.6/cc1': execv: Exec format error
  3. Makefile:918: recipe for target 'main.o' failed
  4. make: *** [main.o] Error 1
Copy the Code

I already reinstalled build-essential, gcc and g++. Stil the same error.
I have also checked if cc1 exists

  1. file /usr/lib/gcc/arm-linux-gnueabihf/4.6/cc1
  2. /usr/lib/gcc/arm-linux-gnueabihf/4.6/cc1: data
Copy the Code

  1. gcc -v
  2. Using built-in specs.
  3. COLLECT_GCC=gcc
  4. COLLECT_LTO_WRAPPER=/usr/lib/gcc/arm-linux-gnueabihf/4.6/lto-wrapper
  5. Target: arm-linux-gnueabihf
  6. Configured with: ../src/configure -v --with-pkgversion='Debian 4.6.3-14+rpi1' --with-bugurl=file:///usr/share/doc/gcc-4.6/README.Bugs --enable-languages=c,c++,fortran,objc,obj-c++ --prefix=/usr --program-suffix=-4.6 --enable-shared --enable-linker-build-id --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --with-gxx-include-dir=/usr/include/c++/4.6 --libdir=/usr/lib --enable-nls --with-sysroot=/ --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --enable-gnu-unique-object --enable-plugin --enable-objc-gc --disable-sjlj-exceptions --with-arch=armv6 --with-fpu=vfp --with-float=hard --enable-checking=release --build=arm-linux-gnueabihf --host=arm-linux-gnueabihf --target=arm-linux-gnueabihf
  7. Thread model: posix
  8. gcc version 4.6.3 (Debian 4.6.3-14+rpi1)
Copy the Code

  1. gcc -print-prog-name=cc1
  2. /usr/lib/gcc/arm-linux-gnueabihf/4.6/cc1
Copy the Code

  1. dpkg -S cc1
  2. g++-4.6: /usr/lib/gcc/arm-linux-gnueabihf/4.6/cc1plus
  3. libgcc1-dbg:armhf: /usr/share/doc/libgcc1-dbg
  4. cpp-4.6: /usr/lib/gcc/arm-linux-gnueabihf/4.6/cc1
  5. libgcc1:armhf: /usr/share/lintian/overrides/libgcc1
  6. ncurses-term: /usr/share/terminfo/x/xterm+pcc1
  7. libgcc1:armhf: /usr/share/doc/libgcc1
Copy the Code


Looks fine so far...
I have not modified the makefile.

Please help!
s33w0lf  
SOLVED
The error occured on Open MediaVault. I tried out original Bananian. After installing some devel packets everything works fine.

I'm running into the same issue. I'm using a banana pi with Open Media Vault.

Can you specify the additional packages you installed?

Which devel packets ?

Thanks

Edited by Mangnoppa at Nov 12, 2015 02:52
webdoctors replied at Sun Oct 18, 2015 08:24
I'm running into the same issue. I'm using a banana pi with Open Media Vault.

Can you specify the a ...

I had the same issue, here is what i did. First i downloaded a newer version of the gcc

  1. apt-get install gcc-4.8
Copy the Code

after changing the directory to /usr/bin with
  1. cd /usr/bin
Copy the Code

I greped after cc with
  1. ls -l | grep cc
Copy the Code

Now you can see all symbolic links too.

Now I changed them to gcc-4.8 with the following commands

  1. ln -s -f /usr/bin/gcc-4.8 /usr/bin/arm-linux-gnueabihf-gcc
  2. ln -s -f /usr/bin/gcc-4.8 /usr/bin/arm-linux-gnueabihf-gcc-4.6
  3. ln -s -f /usr/bin/gcc-4.8 /usr/bin/gcc
Copy the Code

EDIT: If you are not trying to compile WiringBP, you can ignore the next section.

It's now complaining about the lib wiringPi.h, because it is included like this <wiringPi.h> so it has to be in the include path, but obviously it is not.
In every File located in ./wiringPi you need to change the <wiringPi.h> into "wiringPi.h" with any editor, e.g.
  1. nano ./wiringPi/mcp3002.c
Copy the Code


Now you can compile WiringBP on OpenMediaVault.

I hope it will help everyone with that problem.

Best regards
Mangnoppa

You have to log in before you can reply Login | Sign Up

Points Rules