Add-ons

Touchscreen driver problems with Lemaker 3,5" LCD

9 3055
Zom  
Hi,

I just got the l 3,5" touchscreen LCD from Lemaker
the display works fine on my banana pro, but i have some troubles getting the touch panel working.

I followed these two steps for the configuration:
- updated the boot script replacing it with  the latest banana_pro_35lcd.bin file from Github.
- add lcd and  ft5x_ts to /etc/modules

I tried several configuration, and most of the time I get an issue with the ft5x_ts driver (see log info)

Summary of my tests:
config 1:  fresh raspbian image from Lemaker --> touch working
config 2: updated config 1 (apt-get update / apt-get upgrade) --> touch not working
config 3: debian whezzy with kernel 3.4.106 from http://www.igorpecovnik.com: (Bananapi_Debian_2.4_wheezy_3.4.106.zip) --> touch not working

Here what the log says:

ft5x_ts_init: after fetch_sysconfig_para: normal_i2c: 0x38. normal_i2c[1]: 0xfffe
ctp_init_platform_resource: tp_reset request gpio fail!
ctp_init_platform_resource: No power port feature present.
incomplete xfer (0x20)
incomplete xfer (0x20)
incomplete xfer (0x20)
i2c-3, xfer timeout

Can anyone help?
https://dev.bananian.org/view.php?id=111  Please see here, we need a patch to make it work stable under some OS.

Zom  
thank you for your answer

Do you know when it will be integrated in the official downloads?

Zom  
Edited by Zom at Sat Mar 28, 2015 06:30

Hi

I just compiled the debian whezzy with kernel 3.4.106 from http://www.igorpecovnik.com with the ft5x_ts.c patch.
I also tried again with raspbian but it doesn't work reliable either...

ctp is not detected: I still get i2c-3, xfer timeout at initialization

So I think this patch may only be a workaround in some cases but not a stable working solution

Any other idea?

Edit: just found this irc log:
http://irclog.whitequark.org/linux-sunxi/2014-04-30
Maybe something i2c related?

Edited by tony_zhang at Sun Mar 29, 2015 03:28
Zom replied at Sat Mar 28, 2015 06:23
Hi

I just compiled the debian whezzy with kernel 3.4.106 from http://www.igorpecovnik.com with the  ...


For my situation, I have reboot many time under raspbian, the ft5x_ts can work. But I think it is some other reason in the X sever. I have discussed with Nico (Bananian developers ), we do not know why.
One of the disadvantages of I2C is it can not work stable like spi.
I do not check the 3.4.106 kernel with the debian wheezy either.

Zom  
update: I could finally get it working under debian wheezy by including the latest i2c driver in the kernel build

xavier  
Edited by xavier at Fri May 8, 2015 11:20
Zom replied at Sun Mar 29, 2015 06:38
update: I could finally get it working under debian wheezy by including the latest i2c driver in the ...


hey Zom: can you describe how you got it to work and how you included the i2c driver in the kernel build? I have a feeling this is involved but hopefully one can follow what you did...

I have the latest bananian installed and added the ft5x_ts file to my modules list but still no luck getting the touch to work...

thanks!

X

Zom  
Hi,

It is now included in the latest image from Igor (version 2.5 and above)
I have actually no experience with Bananian ...

I too faced same problems on banana pro. I have taken the uk assignment help to identify the errors. After reading this post, I got the solutions for this problem.

This is a common problem in the touchscreen LCD from Lemaker. This article is much helpful to know how to solve these issues easily. The steps for the configurations are shared and it makes easy to implement. Thanks for this informative article. how to turn printer online

You have to log in before you can reply Login | Sign Up

Points Rules