Trouble

No bootmessages with own image (Pi&Pro)

6 1367
Sebster  
Hello.
Let's make it quick:
I've compiled a image by myself from scratch and almost everything works perfectly on BananaPi and BananaPro.
But when I'm booting, there's just the Linux penguin in the right upper corner and the rest of the screen is black.
Honestly I have no idea why this occurs and I hope that somebody out there had the same problem and a fix for that..

the second thing is, that ssh isn't working from boot.
It is installed of course and I can start it manually with "service start sshd" in terminal, but after rebooting the service is not running.
Can somebody explain, why this happens?

Thank you very much
Sebster
For the boot message, you only have to add a new console in kernel's boot parameters.

Sebster  
destroyedlolo replied at Sun Mar 29, 2015 13:09
For the boot message, you only have to add a new console in kernel's boot parameters.

Thanks for your reply!

Can you please explain me, how to do that?

I know how to configure the kernel in the compiling process, but how do I add a new console there?

Greets
Sebster

Add post (Fri Apr 3, 2015 05:17):
.

Sebster  
I've managed to find the kernel parameters.
I'm currently burning the image to my sd-card..
Wish me luck

You don't need to burn a new kernel/image, you need only to create a file named uEnv.txt in your boot partition (if your using LeMaker procedure, it's a FAT one, the one containing the uImage file), and add your kernel options here.
I'm very busy by my job and haven't time to wakeup on my test environment. So let us know if you don't succeed, I'll share how I achieved that

Sebster  
destroyedlolo replied at Wed Apr 1, 2015 14:14
You don't need to burn a new kernel/image, you need only to create a file named uEnv.txt in your boo ...

Thanks for answering again destroyedlolo!
It worked!


Thank you so much! I was looking for that solution for about 2 months or so..

The ssh problem got a solution too so I'm very happy now

Have a nice day!
Sebster

Happy being useful

The only thing that is not working properly in my case, is : as per documentation I found on the net, console message are supposed to go both on the serial console and the LCD screen if I put
  1. console=ttyS0,115200 console=tty0
Copy the Code
But it's not working : uboot own messages goes on the serial and OpenRC goes to the LCD ...

You have to log in before you can reply Login | Sign Up

Points Rules