Android 4.2 Mattrix XBMC Image - (UPDATED 2014.11.11)

178 73032
mattrix  
I used DragonFace and changed what APKS to install etc.
However, I couldn't figure out how to change the initial filesystem

Post Last Edited by LINJEinc at 2014-9-12 00:16

Hi!

New here, and using this version on my BPi.
Have one question. When watching a movie in xbmc, I always get a popup all the
time saying CVBS cable pluged in/out. Using only HDMI to connect my BPi to my TV.
Anyway to stop that anoying popup?

peetr04  
Intresting..
One time i also had this messages CVBS plugged in out.  And this messages popped up continously.  But after reboot disappeared and never come again...  I dont know what could be,  but tis is an existing issue.

Reply 63# peetr04


   will try again then, see if it works. And thanx for the tip.

anyway to get portrait mode on this release?

ChrisP  
Hi,

Found interesting tool to dig a little bit inside the img file: ImgRePacker found here: http://forum.xda-developers.com/ ... 1753473&page=30

On Windows, I can extract some fex file, and extract the boot.fex and the recovery.fex using:
imgRepacker /skip /2nd <path>\STOCK-MOD.img

Still investigating to check if a modification can be repacked as a proper img file. To be honest, I'm far to be convinced that it's possible, but I give it a try.

mattrix  

ChrisP  
Post Last Edited by ChrisP at 2014-9-15 15:55

Yes I saw that. Thanks for it

Having played a little more with imgRepacker, I see some features that I do not see how to do with DragonFace. For exemple getting access to the system filesystem.

Using imgRepacker, I was able to access to system.fex.iso with a ext2 driver. But from Windows I haven't found a way to mount it as R/W. I will test from a Linux box.

However, I tried to repackage a full img from the files extracted at the first step of the process, and was able to burn it on SD and bananapi is starting fine on it. I will continue to investigate that way.

I will try to do some tweaks (French keyboard and default language, figure out how to make the unifying receiver to work ...). DragonFace is fine, but apparently it's possible to do more thing and go a little bit deeper using imgRepacker.
[Edit]
Just realized I only read half of your post. Not sure there are so much difference on filesystem access now. will double-check.

Kuroi  
I tried using the Android image but it didn't work. First I burned it with PhoenixCard to my 2GB Card, it burned without any error, but after trying to boot from it I only got a green screen with the text "Android" on it and a small logo but nothing further happened.

After that, I tried flashing it again since I read PhoenixCard fails like 90% of the time but again, same problem.

Since that didn't work I tried downloading the other image for flashing the other way but I only got a red square on my screen, nothing else.

Does anyone have a suggestion to make it work or is my SD Card just to small for it to work?

Kuroi

Try to do a "clean-Format" with the SD Formatter 4.0 Software.
After that use PhoenixCard again.
Hope this helps...

You have to log in before you can reply Login | Sign Up

Points Rules