Other OS

Openwrt CHAOS CALMER - Stable release, Major Bugs Fixed! - BPI R1

8 6546
Edited by db260178 at Tue May 26, 2015 11:42

Update 24/05/2015 - Have identified the 1 minute disconnect issue:

After debugging the rtl8192cu module, it appears the HW crypto of the rtl8192cu has a race condition causing a complete loss of data flow within a few minutes.

I've changed the kernel module to use the software decryption instead of relying on the HW of the rtl8192cu chip.

I haven't had loss of data or connection since - please post if you are still having issues - Download from 24/05/15 the V1.0.0522 image for this fix!

The speed of the GMAC is still not resolved, but working on further debugging.

(Updated 22/05/2015) - Added SATA pwr to u-boot code on boot. Latest openwrt trunk source!

Hi Banana Pi owners,

Here is my release of the Openwrt Chaos Calmer for the Lamobo R1 board.

I've patched the official trunk sources with a SATA power Regulator fix and enabled the AHCI sunxi driver - Which works now!

I've patched the rtl8192cu driver to fix a deadlock issue experienced if client is connected after a few minutes.

I've enabled the Power ON/OFF switch - but currently acpid is not enabled to do anything with it yet! - in V1.0.0426 release.

Download - R1

Latest Please GOTO Download page!

Previous Release:
OpenWrt-ImageBuilder-V1.0.0426-sunxi.Linux-i686.tar.bz2 1.1GB
openwrt-V1.0.0426-sunxi-Lamobo_R1-sdcard-vfat-ext4.img 220MB (expand with Gparted to use full space)

Any problems please verify the MD5 matches as above otherwise all kind of problems will occur.
Cmdline - md5sum openwrt-sunxi-Lamobo_R1-sdcard-vfat-ext4.img

The following is enabled and works:

* Linux Kernel - 3.18.11
* Wifi is enabled and has the latest patches to fix issues with AP mode and deadlock issues - (1 minute disconnect issue fixed in V1.0.0522 release)
* Switch with VLAN works with default LAN IP enabled on boot - (V1.0.0522 default is
* Recommended packages to make it work out of the box - Web interface, WPA supplicant, Disk tools (mkfs,fdisk etc), ETC ETC

The following still does not work:

HDMI output
No sound

I've seen reports of speed issues - The GMAC glue does not run at the full 1GB/s speed, the BCM53125 does work at full speed

The Google folder has:
See folder 'Latest' for newest version

Previous Release:
OpenWrt-ImageBuilder-V1.0.0426-sunxi.Linux-i686.tar.bz2 - contains the full packages,ImageBuilder
openwrt-V1.0.0426-sunxi-Lamobo_R1-sdcard-vfat-ext4.img - Just The SDCARD image to DD to an SDCARD.

On Windows use Rufus to burn to a micro SD
Linux and others use DD from the command line or Suse studio USB writer.

Default LAN IP = or ( from V1.0.0522)
Default user: root
no password - set from going through the web interface

Connect the lamobo r1 to your pc if your router has the same IP address or use a USB ttl lead on the serial port.

Happy Routing!
Edited by Chilly at Wed May 27, 2015 23:46

Hi db260178,

Is this release of OpenWRT for BPi-R1 also compatible with the original BPi-M1?



No, only for BPI-r1

Great job! Thank you!

Hi Guys, can you please upload the patch and scripts to github so that i can build the openwrt image with all of these fixes?  Thanks so much

Just a nitpick:
I wouldn't call this "stable". Even though it might work very well, OpenWRT Chaos Chalmer has not officially been released yet. But naming a release "stable" suggests otherwise.

silentcreek replied at Wed Jun 3, 2015 03:14
Just a nitpick:
I wouldn't call this "stable". Even though it might work very well, OpenWRT Chaos Ch ...

Stable in the context of the Lamobo R1, not in the actual openwrt release!

But I get what you mean.

natehiker replied at Mon Jun 1, 2015 21:07
Hi Guys, can you please upload the patch and scripts to github so that i can build the openwrt image ...

Just use the imagebuilder (the included tar.gz file) to make a custom image, alot easier than trying to recompile everything and break alot.

Are the rtl8192cu fixes committed to the openwrt project?

Also the problem you describe with disconnects - is that with the bpi-r1 acting as an AP or a client?  Reason I ask is that the AP mode drivers found in the kernel for the 8192cu don't function with more than 1 client at a time in 11n mode.  Many have stopped using the 8192cu kernel drivers and switched to the vendor provided OS realtek drivers.  I know that the raspberry pi images now excludes the kernel 8192cu drivers and uses modified the vendor OS drivers.

Keep up the good work.  this is an great product.

You have to log in before you can reply Login | Sign Up

Points Rules