Trouble

Banana Pi Stuck on Green LED

12 5998
Hi.
I received my BPI-M1 recently and I'm trying desparately to setup my headless server.

There is one drawback, I dont have any hdmi display nor any hdmi to vga converter to attach it to my PC monitor. Unfortunately I cant get any output from av either. Seems none of the OS images output to AV by default.

I saw a clip in youtube where some german setup bananian on sd and booted Banana pi with only a sd card and lan connection, without any hdmi or usb keyboard/mouse. The bpi booted up, first red led, then green and after a little while another led too. Then the device was detectable on lan, and it was possible to ssh in to it.

When i tried the same procedure, i got stuck on green led and there is no network connection (the lan port led's flash but i cant find it on network and router's dhcp server cant see it either), i dont know if the device is stuck on booting process and cant know that without hdmi.

This is my setup:
Banana pi bpi-m1
A tested and working DC 2A adapter
A 2GB nokia micro SD-card (abit old but working on my pc)
A micro-sd to sd socket
And a working lan cable

2GB images i tested:
Bananian 15.04 (stuck on green led)
Berryboit (stuck on green led)
Openwrt (stuck on red led)

All above images got transfered to sd card according to the procedures described in lemaker wiki (tried both windows and linux procedures).


Any suggestions?
tkaiser  
Edited by tkaiser at Wed Jun 24, 2015 04:37

Don't trust any SD card for this purpose without running through either h2testw or F3. And don't trust TF/SD card adapters in general (many are faulty).

And then I would give Armbian a try to see whether the board is able to boot headless. This version http://mirror.igorpecovnik.com/B ... _wheezy_3.4.106.zip is known to boot without hassles (first boot takes approx. 2 minutes since SSH keys are regenerated and some stuff is adjusted and the the board reboots automatically).

Unzip the file, write the image to SD card using the included windows imaging program or as outlined at the Bananian site, try to boot the board, wait 3 minutes, then check the IP address your router assigned and login as root/1234 (you've to change the root password at first login). If that works you know at least your board is working.

BTW: Ethernet should be connected when you power on the board otherwise detection sometimes goes wrong.

Hello,

If the green LED is only on and not flashing, it means the bPI wasn't able to load the kernel (problem with the SD card or its content).

Yes, you can boot only with an SD card (I'm doing it on my bPRO).

It is normal you haven't anything on your screen : the HDMI starts after the kernel.
No kernel == you have to check the serial console.

Bye

Laurent

Thanks for your valuable replies.
I'll report back after testing with a SD card. Hopefully it's nothing.

I will also update my first post with important notes mentioned, So others may find it easier without browsing all pages.

seems I cant Edit my post


No, you can't


can not? Seems I can edit it now. How is the trouble?

Thanks Guys. My problem solved. As you stated, SD Card was the problem.
I bought a Sandisk 8GB class 10 Micro SD Card (tested it with h2testw for fake capacity or speed), wrote bananian image on it, turned on Banana pi and Viola! Red led, then Green led, then green blinking and after few secs, another blue/magneta led turned on too.

I also bought a USB to Serial ttl converter (cp2102 chip, Extra cheap, from SiLabs, only $3 and compatible with win/mac/linux/android) for debugging purposes, checked pins voltages with multimeter (tx/rx should be 3.3v) and connected it to j11 pins of banana pi (refer to gpio layouts), and viola again: i can now see whats happening even before kernel launch. Heavily recommend this.

Good news

You will not regret your $3 : this adapter is a must have for system upgrade if you face early boot issues.

tkaiser  
tony_zhang replied at Wed Jun 24, 2015 23:45
can not? Seems I can edit it now. How is the trouble?

Editing posts just works a small amount of time after creating the post. This behaviour was introduced a few weeks ago. Back then after approx. 2 hours the edit button changed into an "Add" button where you were able to append a few chars (max. 160 if I remember correctly) to your own posts. This is also gone now.

You have to log in before you can reply Login | Sign Up

Points Rules