Discussion

eGalax Touchscreen and Banana Pi

7 10866
ups  
Hi

I want to use a eGalax Touchscreen (HDMI+USB) with a Banana PI. The driver requires uinput support. I tried the official raspbian and suse images but both do not provide uinput. So i compiled my own kernel according to this instruction. That worked so far I got a uinput device but I lost eth0 network (possibliy because of this)

So my question: Is there any way to get uinput support without compiling the kernel or is there a image that supports uimage?
ups  
Problem solved, Tony Zhang provided the required sources and FishX wrote a very nice howto

If you want to use a eGalax Touch just follow FishX howto but stop before
  1. make
Copy the Code
and use
  1. make linux-config
Copy the Code
instead. Then follow the eGalax driver documentation to configure your kernel (I don't patch the sources, just adopt the menuconfig steps) and then run
  1. make
Copy the Code
and follow the howto again.

I don't get the calibration work with eCalib so I used the configuration I got from my Raspi. Open /usr/share/X11/xorg.conf.d/52-egalax-virtual.conf and find
  1. Section "InputClass"
  2.         Identifier "eGalax virtual class"
  3.         MatchProduct "eGalaxTouch Virtual Device"
  4.         MatchDevicePath "/dev/input/event*"
  5.         Driver "evdev"
  6. EndSection
Copy the Code
add
  1. Option "Calibration" "0 4090 0 4090"
Copy the Code
just before EndSection and restart X. That do the trick for me, hope for you too.

BartDG  
Reply 2# ups
Hi UPS,

I want to do the same thing you did, because I've also got an eGalax touch screen. For the input I've got the choice beween DVI and VGA, no HDMI (may I ask you which touch screen you are using BTW?)

I want to use it with my home automation system.  The ideal would be that I could use it with Android, because my home automation manufacturer provides an Android app.  If not I can also use regular Linux, because it works in any browser windows as well.  But regular Linux is not optimized for touch, as you can probably imagine.

I tried this with a Raspberry Pi, but it was too slow (and no Android).  I then bought an Odroid U3, which was plenty fast, but has a hard time providing picture on anything but true HDMI.  Only one of the 3 HDMI to DVI converters I used worked, and even then, only with Linux. It did not work with Android.

So I then returned the Odroid, and now how got 3 options left in my opinion: a Banana Pi (with VGA adapter), a CubieTruck or a dedicated Atom PC miniITX board.  These are in order of cost.

The first thing I'll try now is the Banana Pi.  I'm guessing I'll have to go through the same thing you did (maybe not recompiling, I've found drivers here, but I'm not sure if that'll work and especially not with Android.    It does intimidate me though, because, even though I know my way around computers very well, I don't have much Linux experience, and this is especially so for command line and in-depth stuff.  (doesn't mean I don't want to learn though!)

Thanks

ups  
Hi BartDG,

i got a Faytech T10 SW (FT0100TM) and i got that working with HDMI on a Banana and a Raspberry. I tried that display on my Atom-Netbook running openSuse using VGA and that works fine, too.

I'm not familiar with android but as far as i knew it's just another linux distribution (somehow chained to google, but that shouldn't be a problem in that case) Maybe you try out your display on a known working distribution before you digg into android.

If you got a faytech product, maybe you want to contact the faytech support team. I'm pretty sure they eager to help you to get your display running on your Android-Banana-Setup. I contacted the german support team because of a issue with my raspberry and that people are really eager to help.

It's 4 am here and i really need some sleep. I hope you can work with that and feel free to contact me if you need more information on that or something else.

BartDG  
Hi UPS,

Thanks for your reply.  I've tried a BananaPi and CubieBoard3 on my specific screen, but it doesn't work, I don't get any picture.  (BTW, this is my touch screen.).  It works fine on my 1080p TV though.  

I'm guessing that is the problem: my monitor uses an older 1024x768 resolution.  The TV uses full HD.  I'm guessing most mini computers have a problem with that.  A modern monitor will work no problem probably, but as said, my monitor is a bit older.  The only mini computer that worked no problem was the Raspberry Pi.

I  guess I'll now bite the bullet and simply buy a miniITX Intel ATOM board.  Install Ubuntu on it and then an Android emulator and be done with it. This will be a bit more expensive, but at least I'm sure that will work.

Thanks for your reply!

ups  
Hi BartDG,

on a Raspberry PI you can adjust the screen resolution in /boot/config.txt but the Banana PI use /boot/uEnv.txt and Bananapi.fex/script.bin instead, as far as I can tell. I don't figured out how to manage to change the resolution on the Banana, my touch display works find with Full-HD so I don't need to digg into that...

Maybe you'll compare the prices of a Atom-Board and a new display before you order anything. Possibly you'll save some money using a newer display instead of another board... Or maybe not, but its worth a try ;) The last time I check out the prices Atom-Boards was very expensive.

I thought about trying out the android image on my Banana and my Display but currently I don't have a SD-Card to spare for that. Maybe I'll find a SD and time for that in a few weeks. I'll let you knew if I figure out something interesting.

artist  
Reply 2# ups


    Hi ups,

I have followed the steps as mentioned in your post, but when doing the 'make' step, it throws me this error:
  1. /home/hp/ban/bananapi-bsp/linux-bananapi/drivers/input/touchscreen/egalax_ts.c: In function ‘egalax_wake_up_device’:
  2. /home/hp/ban/bananapi-bsp/linux-bananapi/drivers/input/touchscreen/egalax_ts.c:125:2: error: implicit declaration of function ‘irq_to_gpio’ [-Werror=implicit-function-declaration]
  3.   int gpio = irq_to_gpio(client->irq);
  4.   ^
  5. cc1: some warnings being treated as errors
  6. make[5]: *** [drivers/input/touchscreen/egalax_ts.o] Error 1
  7. make[4]: *** [drivers/input/touchscreen] Error 2
  8. make[4]: *** Waiting for unfinished jobs....
  9.   CC [M]  drivers/media/common/tuners/tuner-simple.o
Copy the Code
Could you help and elaborate more on the steps.

Post Last Edited by vicedens2002 at 2014-9-18 10:11

I am looking for a good 7 inch touchscreen to work with android. ups please provide link for eGalax Touchscreen. I am looking for 90$ touchscreens. This will be used as carputer. All there coupled with gpio buttons.
I am looking at

http://www.ebay.com/itm/HDMI-VGA-2AV-LCD-driver-board-VS-TY2662-V1-7-1280-800-N070ICG-LD1-touch-panel-/200987684727?pt=LH_DefaultDomain_0&hash=item2ecbccaf77

but dont know if the touchpanel works in android or not.

You have to log in before you can reply Login | Sign Up

Points Rules