13 6841
I just got an otg cable.. How does one activate the otg? I tried a keyboard, USB drive . Nothing works.

Post Last Edited by Dliloch at 2014-7-20 06:11

Reply 2# tony_zhang

   Tony,I went to the link but when I type make menuconfig ... I get
make: *** No rule to make target `menuconfig'.  Stop.
I tried a locate on menuconfig but that comes up empty ..there is nothing in /usr/src ???

is there another step I need to do?? thanks..
and one other question.. why not have OTG enabled already??

You only need to modify the script.bin file (the second step). The driver has been opened.

That worked perfectly .. but why did you not enable it to begin with?

Hello, can you give a little more detail about the procedure, i am kinda new to compiling kernel and i am stuck at
"make: *** No rule to make target `menuconfig'.  Stop."

Reply 6# icejack
you only need to config the script NOT THE KERNEL... http://wiki.lemaker.org/index.php?title=Kernel_drivers_porting_and_configuration#Porting_USB_OTG_Driver
do the step config script.fex

my question was why did they not do this in the first place?? It works nicely once enabled..

sorry again but where is the script.fex file? btw am using raspian

no problem .. the first question is where or what is fex2bin and bin2fex .. they are tools to manage the script found in /boot/bananapi  ..
but the script is in a binary format .. so 1st you need to do a bin2fex script.bin
then you can edit script.fex which was created byt bin2fex .. once edited the go
and do fex2bin script.fex and it will replace script.bin
get info on the programs here:
then you will have to download the source
git clone https://github.com/linux-sunxi/sunxi-tools
do a make to create the binaries .
the source will go in /sunxi-tools (root directory)
hope this helps ..

Reply 9# Dliloch

It is because that the OTG cost much CPU resource, so I disabled it by default.

You have to log in before you can reply Login | Sign Up

Points Rules