Discussion

Some problems with screen size

7 14521
deenbee  
Post Last Edited by deenbee at 2014-7-19 21:09

Like hdmi port but my task bar is some down out of my screen border on my TV. Need center the screen to watch task bar complete and upper windows border too.
SO: Lubuntu or OpenSuse the problem is there.

(Android work fine)
rigelk  
Same problem here : images goes off the screen. I am using the v3.0 Raspbian image. Here's what I tried :

Editing the /boot/config.txt as recommanded with RPi. No change is seen on the screen size, even after tweaking the overscan and hdmi_mode values. I thouroughly checked the valid values for my monitor using a GPU check, but only got the following error message.
  1. [E] Failed to initialize VHCI (ret=-1)
Copy the Code
Is this procedure only valid for RPi and not Banana Pi ? Any clue on how to change the screen resolution ? Thanks in advance.

rigelk  
Post Last Edited by rigelk at 2014-7-31 12:02

SOLVED ! I got the problem solved in the end.

As I suspected, /boot/config.txt is a legacy file from RPi which makes extesive use of EDID (auto-detection of screen resoluton by GPU through the HDMI CEC).

The crapy screen resolution auto-detection of the Banana Pi can be bypassed by disabling EDID in /boot/uEnv.txt so that it has a hardcoded value (means no auto-detection, hence settings have to be tweaked if you further change your screen).

Here is the content of /boot/uEnv.txt :
  1. bootargs=console=ttyS0,115200 console=tty0 disp.screen0_output_mode=1280x1024p60 hdmi.audio=EDID:0 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline rootwait
  2. aload_script=fatload mmc 0 0x43000000 bananapi/script.bin;
  3. aload_kernel=fatload mmc 0 0x48000000 bananapi/uImage; bootm 0x48000000;
  4. uenvcmd=run aload_script aload_kernel
Copy the Code
I changed
  1. disp.screen0_output_mode=EDID:1280x1024p60
Copy the Code
to
  1. disp.screen0_output_mode=1280x1024p60
Copy the Code

Fab  
Just tried this, but it does not work for me.

I am on Arch 1.1.1. By the way the /boot directory does not contain uEnv.txt. uEnv.txt is in the first partition, which by default is not mounted.

Anybody has suggestions?

Fab  
Ok, I managed to fix this: in addition to changing uEnv.txt, there was also an obscure setting on the TV side: WideMode = Full | DotByDot. I chose DotByDot and it works just fine.

http://wiki.lemaker.org/FAQ   Here Question 16 has another method to set the resolution.

Fab  
Very useful guide, thanks. Out of the 3 solutions listed there (uEnv.txt, script.bin and /sys/class/graphics/fb0), what is the order of precedence?

For instance, if in uEnv we state 720x576 and in disp_init we state 1920x1080, which one wins?

Hi!
I've got LCD 7" 800x480 connected to BPi by HDMI. BPi run on latest Bananian.
I successfully changed the resolution in console.
  1. echo V:800x480p-60 > /sys/class/graphics/fb0/mode
Copy the Code
it didn't work until I edited uEnv.txt
Now in uEnv.txt I've got:
  1. disp.screen0_output_mode=800x480p60
Copy the Code
and both solutions together started to work.

So far so good, but when I started LXDE resolution came back to 1280x720.
Next I edited /etc/X11/xorg.conf:

  1. Section "Device"
  2.         Identifier      "Allwinner A10/A13 FBDEV"
  3.         Driver          "fbturbo"
  4.         Option          "fbdev" "/dev/fb0"

  5.         Option          "SwapbuffersWait" "true"
  6. EndSection

  7. Section "Monitor"
  8.    Identifier   "Configured Monitor"
  9. EndSection

  10. Section "Screen"
  11.    Identifier   "Default Screen"
  12.    Monitor      "Configured Monitor"
  13.    Device      "Allwinner A10/A13 FBDEV"
  14.    DefaultDepth   24
  15.    SubSection "Display"
  16.       Depth    24
  17.       Modes  "800x600"  "800x480"
  18.    EndSubSection
  19. EndSection
Copy the Code
Unfortunatelly, only 800x600 works. I can't set 800x480. If I leave only 800x480 then LXDE runs on 1280x720...
How can I force 800x480?

You have to log in before you can reply Login | Sign Up

Points Rules