Discussion

Mali GPU driver

135 130437
COmputoman replied at Fri Sep 4, 2015 13:58
I have a huge question for the Banana community. If way back on july 2014 nnn2 found a clean way to  ...

I also would like to know the answer for this...

cst  
nnn2 replied at Sun May 3, 2015 06:42
this is false.

Always check the downloaded image's checksum, if it matches

Your image is great.
However I miss one detail: whether HDMI-CEC is enabled in its custom kernel or not?
I've tried to use cec-utils package, but cec-client can not find any connected TV.

sraeisi  
I am trying to follow nnn2 footsteps to make an image for a media player. as we do not need any Desktop i.e. LDXE etc on this image I was wondering what are the minimum packages we need to make this up an running.

assuming I can install GPU driver after bootstrap, am I right to say "$apt-get -f install xorg mplayer" does the trick to play the movies or I need more packages?

Sdvswef  
Edited by Sdvswef at Tue Nov 3, 2015 21:03

Nice work, could you explain a little more detailed what you have done?
Xpria Z5 cover
Xpria Z4 cover

dluxe  
Juni replied at Jul 25, 2014 14:05
Post Last Edited by Juni at 2014-7-25 14:10

Reply 30# nnn2

Hello, first excuse me for my bad english.

Thank you very much for your awsome work.

I have a problem and hope you guys can help me out.

I followed the steps at Post 31#, but can't compile xbmc.


Here the problems:
- need the source from nr. 3)  *** E: You must put some 'source' URIs in your sources.list ***
=> tested with add-apt-repository ppa:team-xbmc/xbmc-ppa-build-depends

     at apt-get update I get this: Ign http://ppa.launchpad.net wheezy Release.gpg
                                                Ign http://ppa.launchpad.net wheezy Release
                                                Err http://ppa.launchpad.net wheezy/main Sources   404  Not Found
                                                Err http://ppa.launchpad.net wheezy/main armhf Packages   404  Not Found
                                                Ign http://ppa.launchpad.net wheezy/main Translation-en_US
                                                Ign http://ppa.launchpad.net wheezy/main Translation-en
                                                W: Failed to fetch http://ppa.launchpad.net/team-xb ... main/source/Sources  404  Not Found
                                                W: Failed to fetch http://ppa.launchpad.net/team-xb ... nary-armhf/Packages  404  Not                                                     Found
                                                E: Some index files failed to download. They have been ignored, or old ones used instead.
*** SAME ERROR => E: You must put some 'source' URIs in your sources.list ***

- at nr. 14)                                /bin/sh: 2: cmake: not found
                                                make[1]: *** [.builded] Error 127
                                                make[1]: Leaving directory `/root/xbmca10/tools/a10/depends/taglib'
                                                make: *** [all] Error 2

- at nr. 15)                               Can't exec "aclocal": No such file or directory at /usr/share/autoconf/Autom4te/FileUtils.pm line 326.
                                                autoreconf: failed to run aclocal: No such file or directory
                                                make[1]: *** [configure] Error 1
                                                make[1]: Leaving directory `/root/xbmca10'
                                                make[1]: Entering directory `/root/xbmca10'
                                                Warning: No doxygen installed. The Api will not have any docstrings.
                                                make[1]: Leaving directory `/root/xbmca10'
                                                (cd ../../../../; ./configure --prefix=/allwinner/xbmc-pvr-binhf --build=arm-linux-gnueabihf --host=arm-linux-gnueabihf --disable-x11 --disable-sdl --disable-xrandr --disable-joystick --disable-gl --disable-vdpau --disable-vaapi --disable-openmax --enable-neon --enable-gles --disable-mysql --disable-optical-drive --disable-crystalhd --disable-vtbdecoder --disable-pulse --disable-projectm --disable-libcec --disable-optimizations )
                                                /bin/sh: 1: ./configure: not found
                                                make: *** [configure] Error 127
                                                make: Leaving directory `/root/xbmca10/tools/a10/depends/xbmc'

- at nr. 17)                               make: *** No rule to make target `install'.  Stop.


Please help me

qual o comando que uso pra adicionar o drive de video ?
sem precisas compilar ?

zzz3000  
I use nnn2 image. My problem is that mplayer don't show subtitles (by pressing "j" button) and don't show osd(by pressing "o")

I uninstalled mplayer and installed again but then it don't show video at all.

Very sad. How can I build working mplayer inside nnn2 image.

zzz3000  
looks like nnn2 mplayer doesn't support joystick. How to compile mplayer with joystick support?

Mali GPU driver
It does not have a utility to upgrade firmiware?

Build kernel normally, as per here. When you built uImage and modules, make sure it has mali.ko, for example:


The link is gone. Is there another place to see that content?

Thanks
Chris

You have to log in before you can reply Login | Sign Up

Points Rules