Discussion

Mali GPU driver

131 99109
ryjyd  
Post Last Edited by ryjyd at 2014-8-2 22:26

Hi all. This was the big one I was waiting for, and I wanted to share my experience. I'm not a power user, maybe a hare over intermediate.

I snagged nnn2's torrent image a couple pages back and followed the 17 step xbmc build list that juni wrote out most of the way. I was not able to get past "make -C xbmc". So, I took the readme for Linux and apt-"got" the required libs for Linux after a few deletions and gl to gles changes. Retried the last make and made it through. make install did not quite work though, so I have to run the xbmc.bin from the xbmca10 folder in my home directory as root. No sudo, no keyboard. Weird at first, but whatever, it works. I am able to stream from my usual favorites from super repo frodo though I have just sound and no video on a couple of them. Haven't really dug into the logs yet. It also looks fine on both HDMI and composite when it is working. Finally, I get locked up when I exit via the GUI and have to ssh in and reboot. Its way past where I was a couple days ago, but its not quite there. I will test more, try out the /dev/g2d user privilege change after I catch up on a few shows.

I would like to see nnn2's adaptation up on the downloads page with maybe a couple changes, like add wicd and a browser. Call it BananaBlack - Debian Mali reMix. I don't really see a banana distro, just raspberry adaptations. This should be the top banana, no monkeying around. People will go ape for this one. (These banana jokes doing anything for ya?)

I can't thank the community here enough. I learn a little more each day, and I have a little more fun each day. Hats off to you all. Now, I will go rot my brain out with some TV instead of code.

Reply 38# nnn2


    Hi nnn2, what is the "it's a program that has a list of all movies released on torrents" - i have tried to collect torrent for movies and yours could be what i am looking for. Thanks.

nnn2  
Reply 52# EricaTee


   I was thinking of Popcorn Time, but I still haven't made any progress for that, it's kinda complicated to port, and github took down their project pages due to DMCA bullshit complaints :/

ryjyd  
Post Last Edited by ryjyd at 2014-8-4 08:40

Has anyone had xbmc exit cleanly yet? Many things are working, but the sql thing and a clean exit is an issue here. I can start it and run it rooted, haven't bothered with /dev/g2d yet, i'll get to it later.
[edit] Nevermind. I got xbmc to exit cleanly by telling it to reboot. It didn't reboot, but I don't have to flip the system anymore. Go figure. [/edit]

muf  
Why you don't use the official xbmc with mplayer as external player ?

iser  
Post Last Edited by iser at 2014-8-9 01:55

Reply 55# muf
Actually I have such configuration, h264 1080p works fine even with DTS sound passthrough, but mplayer competes for OpenGL surface with XBMC and it is blinking as a result.

ged  
Reply  Juni

There is one problem with it though, blinking white cursor on top of xbmc.
nnn2 Posted at 2014-7-26 10:11


From ProgramOften's youtube video on CubieTruck+FB+XBMC

If you want to turn off the blinking cursor run "setterm -cursor off" before running xbmc.

Thanks for nnn2's image.  It works perfect for FULL HD playback.
I wanna to set the desktop to portrait.  I tried xrandr -o left.  But it got errors as below:

banana@banana:~$ xrandr -o left
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  149 (RANDR)
  Minor opcode of failed request:  2 (RRSetScreenConfig)
  Serial number of failed request:  14
  Current serial number in output stream:  14

And Also, is there a way to use gnome-mplayer with the environment variables:
•  export DISPLAY=:0
•  export VDPAU_DRIVER=sunxi

nnn2  
Reply 58# odbwilson


   After you install gnome-mplayer you can try, to do that edit /usr/bin/mplayer-wrapper which is a script I made to start mplayer with all env variables. It is used when you double click files etc. Change mplayer to gnome-mplayer there, but no guarantee it works

Reply 59# nnn2


    I thought the mplayer-wrapper was the gui version of mplayer. I have noticed if you run the player in console mode it does load the video but does not play it. If you use the keyboard to fast forward the movie you'll see what I mean.

You have to log in before you can reply Login | Sign Up

Points Rules