Add-ons

BaiDu WIFI on BananaPi

30 8959
rbarua  
Reply 10# rbarua

Finally, Able to load ra0 with mt7601u. I have followed following Threads with linux_bananapi 3.4.90 kernel:

http://www.raspberrypi.org/forums/viewtopic.php?p=392591#p392591   // for building the module mt7601usta

&

http://forum.lemaker.org/viewthread.php?tid=1817&highlight=coherent  // for coherent_pool error in dmesg

I am able to connect to my router but no internet through ra0. Can someone help ?

I have setup /etc/network/interfaces for ra0.

Post Last Edited by sashijoseph at 2014-8-20 01:20

Post Last Edited by sashijoseph at 2014-8-20 01:03
can you go online through LAN?

rbarua  
Reply 12# sashijoseph


   I have fixed it. Issue was default gateway was not getting set for ra0. So made following modification & it worked:
iface ra0 inet static
        address 192.168.1.201
        netmask 255.255.255.0
        geteway 192.168.1.1
        up route add gw 192.168.1.1

Post Last Edited by Beetlejuice at 2014-8-19 23:53

Hi,
rbarua, can you explain me how to create the folder /lib/modules/3.4.90/build please ?
or maybe make a tutorial with the step you had to do to compile the driver ...
I've the same wifi dongle, and i can't success to make the driver for this kernel !
THX

rbarua  
Reply 14# Beetlejuice

   Assuming you can connect to eth0 for getting internet on your Bananapi board:
   sudo git clone https://github.com/LeMaker/linux-bananapi  /usr/src/linux_bananapi
   ln -s /usr/src/linux_bananapi /lib/modules/3.4.90/build

   If you cant connect to eth0, then download from git and copy it to your sdcard. And link it as mentioned above to your build.

-rbarua

Hello,
No luck, i still can't compile it
I've this error :
/bin/sh: 1: scripts/genksyms/genksyms: not found
make[2]: *** [/home/bananapi/MT7601U/os/linux/../../os/linux/rt_usb_util.o] Erreur 127
make[1]: *** [_module_/home/bananapi/MT7601U/os/linux] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux_bananapi »
make: *** [LINUX] Erreur 2


Rbarua, could you give me your compiled files ? maybe they will work for me ...
thx for you help

Reply 16# Beetlejuice
You could try this...
cd into your linux source directory.
  1. make mrproper
Copy the Code
then copy over the .config file (zcat /proc/config.gz > /my_kernel_source_dir/.config)
you may also copy over the Module.symvers file provided by Tony in another thread.
  1. make menuconfig
Copy the Code
  1. make prepare
Copy the Code
  1. make scripts
Copy the Code
Now try and compile your driver.

rbarua  
Reply 16# Beetlejuice


   I have uploaded in github:https://github.com/rajeshbarua/MT7601USTA


Hope it will work for you.
Regards
Rajesh

Hi !
Still no working GGGGRRRRR !!

#sashjoseph, With your advice, i'm now able to compile the driver ( I just had to install libncurses)
But if i try instmod mt7601Usta.ko , i get a " invalid format".
In my makefile, the platform is set for PC, is it right ?

#Rbarua, I can "insmod ..." your file but it dont work for me.

The ifconfig command show only ETH0 and lo .

there is an error returned by the dmesg command :

[ 1052.391653] rtusb init rt2870 --->
[ 1052.393605] ===>rt2870_probe()!
[ 1052.398043] --> RTMPAllocAdapterBlock
[ 1052.403650]
[ 1052.403655]
[ 1052.403658] === pAd = f3975000, size = 851128 ===
[ 1052.403662]
[ 1052.406201] --> RTMPAllocTxRxRingMemory
[ 1052.416290] ERROR: 256 KiB atomic DMA coherent pool is too small!
[ 1052.416296] Please increase it with coherent_pool= kernel parameter!
[ 1052.433045] <-- ERROR in Alloc Bulk buffer for HTTxContext!
[ 1052.435584] ---> RTMPFreeTxRxRingMemory
[ 1052.438127] <--- RTMPFreeTxRxRingMemory
[ 1052.438978] ERROR!!! Failed to allocate memory - TxRxRing
[ 1052.446720] <-- RTMPAllocAdapterBlock, Status=3
[ 1052.451160] rt2870: probe of 3-1:1.0 failed with error -1
[ 1052.458405] usbcore: registered new interface driver rt2870


Thx a lot to you two for your help . It's very nice

Post Last Edited by Beetlejuice at 2014-8-22 07:29

Humm .. i see that you gived this link Rbarua :
http://forum.lemaker.org/viewthr ... &highlight=coherent

I'll read it !!
EDIT : nothing still the same error

You have to log in before you can reply Login | Sign Up

Points Rules