Add-ons

BaiDu WIFI on BananaPi

32 9241
rbarua  
Reply 20# Beetlejuice

So after modifying coherent_pool=2M, you are still finding same error in dmseg ?
Regards
Rajesh

Post Last Edited by Beetlejuice at 2014-8-22 10:19

Post Last Edited by Beetlejuice at 2014-8-22 10:19

Post Last Edited by Beetlejuice at 2014-8-22 10:18

Yes,coherent_pool=2 wasn't present in the option . So i've added it at the end of the line, just before "rootwait" and i've restarted the RBPI .

But i've still this message .

EDIT : I've tryed to put coherent_pool=2 at the start of the line and Ra0 appeared with the ifconfig command

Now i must understand how to connect to my internet box

Argh ! I must Redo " sudo insmod mt7601Usta.ko " each time i restart the RBPI !

rbarua  
Reply 23# Beetlejuice

Hi,

   You need not do insmod everytime. Please follow later steps of below thread :
http://www.raspberrypi.org/forums/viewtopic.php?p=392591#p392591   // for building the module mt7601usta


-Rbarua

You talk about this step ?
depmod -a

With this command , ra0 isn't show with the command ifconfig .

rbarua  
Reply 25# Beetlejuice
Actually I was mentioning about similar steps for Bananapi as following:

pi@raspberrypi ~/src/DPA_MT7601U_LinuxSTA_3.0.0.3_20130717_LS $ mkdir -p /etc/Wireless/RT2870STA
pi@raspberrypi ~/src/DPA_MT7601U_LinuxSTA_3.0.0.3_20130717_LS $ sudo cp RT2870STA.dat /etc/Wireless/RT2870STA
pi@raspberrypi ~/src/DPA_MT7601U_LinuxSTA_3.0.0.3_20130717_LS $ sudo cp MODULE/os/linux/mt7601Usta.ko /lib/modules/3.6.11+/kernel/drivers/net/wireless/
pi@raspberrypi ~/src/DPA_MT7601U_LinuxSTA_3.0.0.3_20130717_LS $ sudo cp UTIL/os/linux/mtutil7601Usta.ko /lib/modules/3.6.11+/kernel/drivers/net/wireless/
pi@raspberrypi ~/src/DPA_MT7601U_LinuxSTA_3.0.0.3_20130717_LS $ sudo cp NETIF/os/linux/mtnet7601Usta.ko /lib/modules/3.6.11+/kernel/drivers/net/wireless/  

Add "mt7601usta" at the end of /etc/modules

-Rbarua

Post Last Edited by Beetlejuice at 2014-8-23 06:34

Post Last Edited by Beetlejuice at 2014-8-23 05:55

Thx for your help,
Finally i've restarted all from zero, and ... It work !!
Almost, i haven't set it yet, but the driver is well loaded at start .

EDIT : Oh no !! it not work after 2 reboot !!
dmesg show this error :

[   22.152047] mtnet7601Usta: Unknown symbol Rtmp_Drv_Ops_usb (err 0)
[   22.252459] usb_storage: disagrees about version of symbol module_layout
[   22.299435] mt7601Usta: exports duplicate symbol rausb_autopm_get_interface (owned by mtutil7601Usta)

AND EDIT AGAIN ! lol : It work again now ... i'll wait a little bit before give you news

Post Last Edited by Beetlejuice at 2014-8-24 02:11

Hello !

So, the driver work well but it don't connect itself to the lan at start .
I've installed a VNC server, and i can connect to it when the "log screen " appear so i can choose the user .
Do you know how to do for have my wifi connected before oppening a session ?
The goal is to use the raspberry in my robot . So i must be able to connect to it without display, keyboard and mouse ....

Hello,
Sorry for the long time without comming here, i was sick

So, today i've restarting to configure my BananaPI and the Wifi work well BUT ... it work only
if the ethernet is connected !!!

If i start the BananaPI without the ethernet cable pluged, the wifi doesn't appear in Network manager .
And the goal is to have the wifi connected before login to my session like with the ethernet .

I've read something about edit the file "interface", but my wifi key is WEP and not WPa so i don't know how to do it ( i need to keep WEP because the Nintendo DS of my daugthers don't accept WPA ...)
And as the BPI will be in a mobile robot, it need to be able to connect automaticly to an open network or one that it know the key ...

Someone can help me to do this please ?

Thx

uuuuh....

I have insmod the .ko (mt7601Usta   780196   0  is list)and modified coherent_pool=2M, BUT I still could find Nothing about Ra0 when using ifconfig...

Is there any other Issus should be Noticed?  Thx!



You have to log in before you can reply Login | Sign Up

Points Rules