Other Projects

Can't run RetroPie emulation under Raspbian v3.0

16 12929
I had run the Raspbian v3.0 for BananaPi successfully.

and I execute the RetroPie (the newest) installation script and then finished.

But when I run the emulationstation command, I got a wrong message:
* failed to open vchiq device

Can the Banana's RDs fix the problem? (run under the Raspbian/Raspberry is ok)
Reply 1# gnimnek168


What interface did RetroPie use? I did not have one.

Reply 2# tony_zhang

Hello~

you can check this: http://blog.petrockblock.com/retropie/

RetroPie just a open-project for all the games of emulator stations. It can be installed by setup script.

Reply 1# gnimnek168
That is not going to work on BIP the "vchiq device" error is a specific hardware error to raspberry pi and it's only looking for raspberry pi hardware to run.

Hope that helps...

Reply 4# Shaka_Flex

Sorry, It's no any helps to me.....

I wish the vendor of Banana Pi can fix the problem. But I don't expect them can.
anyway, I would not buy the cloned Raspberry Pi But not 100% cloneable Banana Pi......

The Banana Pi is a bad Banana........., I hate to eat it anymore ..................

Reply 5# gnimnek168

Im sure the vendor of banana pi can fix it, but they are not the developers of the RetroPie software.
You can compile and port all the emulators on the BPI, it just takes time.

Reply  gnimnek168
That is not going to work on BIP the "vchiq device" error is a specific hardware  ...
Shaka_Flex Posted at 2014-8-3 11:00


It's strange that it would depend on raspberry pi specific hardware because EmulationStation will run on different platforms including Debian.
but,
I followed the instructions to build it  for Debian  rather than the pi, but got the same error

yea it wont ever build. it was made for arm6 and the raspberry pi CPU

ryad  
RetroPie does not work, because the distribution you have is compiled for Raspberry Pi. The vchiq error comes, because the Banana Pi does not have the Raspberry VC GPU but a Mali GPU. That's it.

Of course you can compile RetroArch and emulationstation for yourself and configure it, so that it looks the same like in RetroPie. This is no big deal, but unfortunately there is no out-of-the-box solution (at least I don't know any).

Reply 9# ryad


   I did compile ES from source and I used the instructions for Debian, not the ones for Raspberry Pi.   http://emulationstation.org/gettingstarted.html#install_deb

I built SDL2, checked the dependencies ,then built ES. (no errors)


I had thought that because Debian can run on a hardware other than the Raspberry Pi, it would not compile specific PI code.
Or possibly the compiler is detecting the BananaPI as RaspberryPI
But I'm still learning so could be completely wrong.!

You have to log in before you can reply Login | Sign Up

Points Rules