Discussion

Audio out mode setting (CB for Banana Pi image)

18 33301
VasCr  
Kulli replied at Thu Oct 2, 2014 02:17
Post Last Edited by Kulli at 2014-10-2 02:18

Hey,

Same problem here.
I can hear the test but nothing else like playing an mp3 file.

jirkaz  
Bjoern replied at Sat Sep 6, 2014 13:32
Hi, below an update:
I created /etc/asound.conf (not present in your distibution?) to turn on the he ...

I guess // is bad comment, try use # as comment or delete comments at all.

jirkaz  
VasCr replied at Wed Dec 10, 2014 02:20
Same problem here.
I can hear the test but nothing else like playing an mp3 file.

If you are using mpg123 try mpg321

Edited by grzegorzc at Mon Jan 12, 2015 14:30

For those who would like to have the sound on both outputs simultaneously (hdmi + analog), this is my working asound.conf (Banana Pi - Raspbian v1412):
  1. pcm.!default {
  2.         type plug
  3.         slave {
  4.                 pcm both
  5.         }
  6. }

  7. ctl.!default {
  8.         type hw
  9.         card 0
  10. }

  11. pcm.analog_hw {
  12.         type hw
  13.         card 0
  14.         device 0
  15.         channels 2
  16. }

  17. ctl.analog_hw {
  18.         type hw
  19.         card 0
  20. }

  21. pcm.hdmi_hw {
  22.         type hw
  23.         card 1
  24.         device 0
  25.         channels 2
  26. }
  27. ctl.hdmi_hw {
  28.         type hw
  29.         card 0
  30. }

  31. pcm.multi {
  32.         type multi;
  33.         slaves.a {
  34.                 pcm analog_hw
  35.                 channels 2
  36.         }
  37.         slaves.b {
  38.                 pcm hdmi_hw
  39.                 channels 2
  40.         }
  41.         bindings.0.slave a
  42.         bindings.0.channel 0
  43.         bindings.1.slave a
  44.         bindings.1.channel 1
  45.         bindings.2.slave b
  46.         bindings.2.channel 0
  47.         bindings.3.slave b
  48.         bindings.3.channel 1
  49. }

  50. ctl.multi {
  51.         type hw
  52.         card 0
  53. }

  54. pcm.both {
  55.         type route
  56.         slave {
  57.                 pcm multi
  58.                 channels 4
  59.         }
  60.         ttable.0.0 1.0
  61.         ttable.1.1 1.0
  62.         ttable.0.2 1.0
  63.         ttable.1.3 1.0
  64. }

  65. ctl.both {
  66.         type hw
  67.         card 0
  68. }

Copy the Code

Comments

This is perfect! Thank you.  Post time Oct 18, 2015 18:18

if anyone is still having issue after adding asound.conf and changing the comments to # or removing the comments I found something else that might work.  In the terminal type sudo raspi-config go to advanced options, then go to audio then force whatever you want.  I haven´t done this myself so don´t hold me responsible if your banana explodes in the process.

Edited by jorricks at Mon Mar 16, 2015 14:02

@tony_zhang
Hello,
So I tried this too..

jorricks@bananapi:~$ sudo alsamixer
cannot open mixer: No such file or directory

I am using IGOR's image (3.19, ubuntu)
http://www.igorpecovnik.com/2014/09/07/banana-pi-debian-sd-image/

I have no idea how to get this working.. I need it for this tutorial: http://www.raspberrypi.org/forums/viewtopic.php?f=38&t=68779
Do I need some kernel drivers/modules for this or??

Kind regards,
Jorricks

mmax  
I have the same probelm with new bananian 15.08

igorpec  
Edited by igorpec at Mon Aug 31, 2015 19:33

There is no audio support / driver in kernel different than 3.4.x

Yet.

You have to log in before you can reply Login | Sign Up

Points Rules