Trouble

Compiling driver for DVB-C stick (TT CT2-4400) SOLVED

51 30758
Hi Maxwell
Your earlier error with "make install" was due to your host machine's "strip" program being used instead of the arm one.
You could rename the "strip"  executable in /usr/bin and copy over the arm one from /usr/arm-linux-gnueabihf/bin  or wherever it is.

Seems you're close...good luck.

maxwell  
Hello sashujoseph,
you are "the bomb". Another great help from you, thanks. Sounds totally plausible and I will try as soon as I got my fresh 32bit cross compiling vm completely set up.

I can almost see that damn dvb-c stick working on the BPi soon. :-D

Thanks again and I keep you posted.

maxwell  
Post Last Edited by maxwell at 2014-8-5 18:13

That totally worked! I did as you said and "make install" went perfectly fine. The whole compilation was pretty straight forward with yout tip to edit .myconfig, just had to edit 4 entries.

Now I am pretty happy to finally have built the media_build from my stick manufacturer. Still I don't get the stick initialized just the same old story:

  1. [    3.905938] usb 3-1.4: New USB device found, idVendor=0b48, idProduct=3014
  2. [    3.919088] usb 3-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
  3. [    3.930452] usb 3-1.4: Product: TechnoTrend USB-Stick
  4. [    3.939172] usb 3-1.4: Manufacturer: CityCom GmbH
  5. [    3.947184] usb 3-1.4: SerialNumber: 20131128
Copy the Code
not the DVB-Part. I just copied the whole compiled "/lib/modules/..." to my BPi and rebooted. Pretty sure that is not the best way to do as it broke the detection of my USB smartcard read that is sitting on "/dev/ttyUSB0"

What are the files in "/lib/modules/3.4.90/" for? (modules.alias etc.)
Should I just copy over the compiled "/lib/modules/3.4.90/kernel/drivers/media" as there are sitting those media modules?

Nontheless, very thankful for your help. Learned quite a lot the last 48 hours already. :-)

UPDATE
OK, obviously those "modules.*" files in "/lib/modules/3.4.90" DO make a difference with detection of hardware. Restoring the origirnal BPi files, the smartcardreader is back online. I noobly put some of the IDs I notice from the compiled mudules.alis into the original ones and so on and hoped this would work. You see, I take deperate measures :-D

On another note, now, after soooo much playing around on the BPi, even my since working hauppauge dvb-c stick isn't really showing up as a dvb device. I guess I will reinstall that whole BPi as a last shot.

Cheers
Maxwell

Hi Maxwell...
After cross compiling,you could compress the whole media-bst folder,transfer it to BPi and then run "make install" in Bpi itself.
As an added precaution you could first save a compressed copy of the /lib/modules directory(offline ofcourse as some modules maybe in use) just in case sth goes wrong with "make install" and you need the original module tree.
btw did you add the arm sit.o while compiling?

maxwell  
Post Last Edited by maxwell at 2014-8-6 07:36

Hi sahijoseph,
slowly I start to feel a little stupid to not come up with those things as I normally think about myself as quite tech saavy. 20 years of Windows must have taken its toll on me. ;-)
BUT: Another day, another day of awesome learning :-)

So I assume that the "make install" will handle the files in "/lib/modules/3.4.90/modules.*" and add the needed entries and so on? Is that how it works?

I will of course try that out! Thanks again! Victory is near! ;-)

And yes, I added the ARM sit.o to the V4L directory before compiling. I am still waiting for an answer from Technotrend tech support to tell me exactly which modules (tuner, frontend ...) are essential for my stick. I will try to make a customized install for the future. For now they just posted me the ARM sit.o that was available on their (Satelco) FTP servers.

UPDATE
I found a nice read about module making with explanations for those files in the module tree. So yes, simply copying over the *.ko isn't gonna work. I cannot wait to get back to my BPi to try the "make install" on it.

The Link: http://wire-less-comm.blogspot.d ... modules-faster.html

Thanks again and cheers
Maxwell

maxwell  
Great, the "make install" on the BPi with cross compiled media_build worked like a charm and the "/lib/modules/3.4.90/modules.*" got updated!

Sounds like a final victory? Not quite ;-) That stick still does not show up as a DVB device, just as USB, but so does not my confirmed to work Hauppauge stick! That's why I don't feel like I lost some good night's sleep. I will setup a quick, almost vanilla BPi on another card and repeat the steps I did to make the faulty Hauppauge stick work and add the new one in the mix. Pretty sure at least one of them will start to work again.

Thanks for for the great help so far. I will post when I tried the new SD card.

Cheers
Maxwell

Maxwell does the stick work on your (Linux) PC?
If so,you could figure out the modules used by it and try modprobing those very modules in BPi.

maxwell  
Hello sashijoseph,
yes the stick works perfectly on the linux pc (in the virtual mashine). I am having some help files open for modprobing and try to figure it out. Good idea!

I actually tested a vanilla BPi installation to see if my faulty Hauppauge stick gets recognized and it works right away, just had to copy a firmware file over. After I "make install" the media_build thing for my new stick, support for my Hauppauge stick is broken and sadly the new stick doesn't work. I see that the subdirs in "/drivers/media" from the vanilla install differ A LOT, also the file sizes of each module differ quite a bit (ok, other versions, but EVERY file?).

VERMAGIC for vanilla modules is:
3.4.90 SMP preempt mod_unload modversions ARMv7 p2v8

for the cross compiled media_build modules (just checked some):
3.4.90+ SMP preempt mod_unload modversions ARMv7 p2v8

Could the "+" be a problem?

I feel I am getting sooooo close.

Cheers and thanks
Maxwell

maxwell  
Post Last Edited by maxwell at 2014-8-6 17:33

Post Last Edited by maxwell at 2014-8-6 17:04

Here comes the relevant lsmod info after the stick is correctly activated:

  1. Module           Size   Used by
  2. rc_tt_150        12502  0
  3. sit2fe           42754  1
  4. dvb_usb_dvbsky   19625  0
  5. dvb_usb_v2       36018  1 dvb_usb_dvbsky
  6. dvb_core         121620 2 dvb_usb_v2,dvb_usb_dvbsky
  7. rc_core          28398  4 rc_tt_1500,dvb_usb_v2,dvb_usb_dvbsky
Copy the Code
I will try to "modprobe -f" those modules and see if something happens :-D

UPDATE
OK, the '+' symbol is done by the .git folder. Something about not commited, changed source or whatever. When I cross compiled the BPi kernel all stuff got the '+' added to the version string. I just renamed the .git folder and with "scripts/setlocalversion" I see no "+" nor more. Next time I need sources I just tarball me the source. Recompiling the kernel right now.......

UPDATE2
Kernel compiled, media_build rebuilt with just the essential modules, "make install" on BPi without errors. MODINFO gives me exact version string as vanilla modules (see previous post).

  1. DMESG output after some "modprobe sit2fe" and "modprobe -f sit2fe"

  2. [  481.600359] sit2fe: disagrees about version of symbol module_layout
  3. [  503.935448] sit2fe: module_layout: kernel tainted.
  4. [  503.939783] Disabling lock debugging due to kernel taint
Copy the Code
I give up for tonight.

Cheers
Maxwell

maxwell  
No news on the BPi front, but, with my new knowledge ;-) , I am giving the cross compilation for the RPi another shot and see how that goes.
If someone is still reading here, maybe you guys have more advice for my last posts.

Thanks and cheers
Maxwell

You have to log in before you can reply Login | Sign Up

Points Rules