Trouble

Compiling driver for DVB-C stick (TT CT2-4400) SOLVED

51 30755
maxwell  
Ok, compiled everything one more time, inlcuding new pull from git. Can test in the next couple of hours. Maybe there was just discrepancy in file versions.... I will respond later on.

Post Last Edited by Ligachamp at 2014-8-19 01:39

Hey Maxwell,

I'm sorry that I didn't response earlier, but I was a week on holidays :/
My last try went bad, so I didn't get lot further... I hope your try went better?

I'm going to try to compile the Kernel on dr BPi itself, cause I don't have a working Linux Desktop machine here on work... I hope it goes better.


EDIT: I didn't see that the post grew up over 5 pages ^^" I've read all the answers, but no one helps me really further... Sincerly, I'm not very familiar with kernel compiling and that stuff (the only things I ever compiled were some small C programs....). Could somebody please post some kind of "step by step instructions"? Fiddling around with this things makes me mad :S

Ligachamp

If you just want the thing working you could pm Maxwell for the modules he compiled...I'm sure he'll help you out.

maxwell  
Exactly, I already proposed the idea of a PM to him :-)

I will get reinvolved into Banana Pi in september again, work.
Keep up the great help guys.

Lars_19  
Hey there,

I like your work, I wonder if it's possible that I also can get the File - my BPI and my CT2-4400 looking forward to have some tasks :-)


Many Thanks in advance

Cheers
Lars

Hello everybody,

hoping there is still someone reading this thread especially as I bought the stick because of post #21 ;-)

To be honest I am not a Linux pro...however I managed to cross compile the modules in a Xubuntu 14.04 VM for my Bananian Linux (Linux bananapi 3.4.104+). On the Banana Pi the drivers seem to install properly as I can see now the device /dev/dvb/adapter0. For me there is also no need to force the modules - if I force them I get the "exec format error"... After rebooting my Pi I get following result from "dmesg | grep usb" which looks not too bad to me:
  1. [   15.804917] usb 2-1: dvb_usb_v2: found a 'dvbsky-TVStick CT2-4400' in warm state
  2. [   15.893043] usb 2-1: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
  3. [   15.940763] dvbsky_usb MAC address=bc:ea:2b:44:03:65
  4. [   15.963675] usb 2-1: dvb_usb_v2: MAC address: bc:ea:2b:44:03:65
  5. [   16.082498] usb 2-1: DVB: registering adapter 0 frontend 0 (Sit2 DVB-T2/C)...
  6. [   16.157082] input: dvbsky-TVStick CT2-4400 as /devices/platform/sw-ehci.1/usb2/2-1/rc/rc0/input2
  7. [   16.180124] rc0: dvbsky-TVStick CT2-4400 as /devices/platform/sw-ehci.1/usb2/2-1/rc/rc0
  8. [   16.200915] usb 2-1: dvb_usb_v2: schedule remote query interval to 300 msecs
  9. [   16.222483] usb 2-1: dvb_usb_v2: 'dvbsky-TVStick CT2-4400' successfully initialized and connected
  10. [   16.228391] usbcore: registered new interface driver dvb_usb_dvbsky
Copy the Code
The stick also shows up in tvheadend as adapter but now I am stuck as nothing I configured revealed channels (yes, the adapter is checked 'enabled'). This is most likely since I am a newbie to tvheadend. Therefore I tried to check the stick differently in an less error prone way which is not so obvious... My try via dvb-apps didn't work either.

Now my question. How can I easily check if my driver works on my Banana Pi (the stick functions on Windows besides from a sound issue after +/-30 seconds...)?

Any help is really appreciated!

Trying again the dvb-apps scan program seems to narrow down the issue. On my Xubuntu 14.04 the command lists some channels whereas on my BananaPi I am getting an error:
  1. scan /usr/share/dvb/dvb-c/de-Kabel_BW
  2. scanning /usr/share/dvb/dvb-c/de-Kabel_BW
  3. using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
  4. initial transponder 114000000 6900000 0 5
  5. >>> tune to: 114000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_256
  6. WARNING: >>> tuning failed!!!
  7. >>> tune to: 114000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_256 (tuning failed)
  8. WARNING: >>> tuning failed!!!
  9. ERROR: initial tuning failed
  10. dumping lists (0 services)
Copy the Code
Maybe it's due to one of the 4 or 5 v4l modules I had to exclude from the build... Any suggestion what I could do? Thanks in advance!

Edited by zaphod2014 at Sat Nov 29, 2014 21:05

It's working now.

Finally I compiled the official v4l media_build from linuxtv.org for my Bananian linux 3.4.104+ and not the one provided by technotrend (i.e. no struggling with the sit2.o library). However I am now on my own kernel as I had to enable the kernel option CONFIG_I2C_MUX but I only replaced uImage and nothing else. Since my stick is already a V2 model I had to manually apply a patch on the media_build modules (details). I also had to enable in .myconfig the module CONFIG_DVB_SI2168. Then I copied the compiled media_build folder to my BPI and after the make install the stick was working. It might be that after a reboot the stick is back in DVB-T mode which is not what I need for tvheadend. A "dvb-fe-tool -d DVBC/ANNEX_A" in the tvheadend start script takes now care.

Good luck for everybody else who considers running the stick on a ARM computer.

Hello,

could one of you maxwell or zahpod2014 be so kind and make a copy/paste instruction of how to run the stick on banana pi? Probably the easiest way will be to upload somewhere the results of your compilations and to explain how to make it work.

Thank you in advance

Edited by SebastianM at Fri Jan 16, 2015 17:04

no one? I have also the TT 4400 DVB-T Stick and need help to bring it online

I am working on an Quick Guide, but at this moment i dont have an working firmware. I will report my steps

You have to log in before you can reply Login | Sign Up

Points Rules