Trouble

Rotate display

7 9303
hello, good afternoon, I have a problem and I can not rotate the screen of my banana pi.
I use the hdmi output for this purpose, but no meeting between the settings section to rotate the screen 90 degrees, use xrandr command but does not work, but I wanted to use framebuffer mark errors, I have no idea how to change my screen place at 90 degrees, one can help me I'm no expert so I was quite complicated to understand the functioning of these systems.
I hope you can help me.

vercion use of Lubuntu_For_BananaPi_v3.1
***Push***

/etc/X11/xorg.conf
Section "Device"
        Identifier      "Sunxi FBDEV"
        Driver          "fbturbo"
        Option          "fbdev" "/dev/fb0"
        Option          "SwapbuffersWait" "true"
        Option "rotate" "CW"
        Option "SwapAxes" "True"
        Option  "InvertY" "True"
        Option  "InvertX" "True"
EndSection

Edited by DaveTheMinion at Tue Dec 2, 2014 18:19

Here is what I did to rotate my 7-inch touchscreen:

1. Edit /boot/uEnv.txt

Add the following entry:
  1. fbcon=rotate:2
Copy the Code
This caused the framebuffer (e.g. the normal text console) to be rotated by 180 degrees.

2. Create /etc/X11/xorg.conf.d/02-monitor.conf with this content:
  1. Section "Device"
  2.         Identifier "Sunxi FBDEV"
  3.         Driver "fbturbo"
  4.         Option "fbdev" "/dev/fb0"
  5.         Option "SwapbuffersWait" "true"
  6.         Option "rotate" "UD"
  7.         Option "HWCursor" "false"
  8. EndSection
Copy the Code
The last two entries are responsible for the rotation.

3. If you have a touchscreen you maybe have to do the following: In the file /etc/X11/xorg.conf.d/01-input.conf the "Invert" entries have to be:

  1. Section "InputClass"
  2.         Identifier      "calibration"
  3.         MatchProduct    "eGalax Inc. Touch"
  4.         Option  "Calibration"   "37 1985 104 1956"
  5.         Option "EmulateThirdButton" "1"
  6.         Option "EmulateThirdButtonTimeout" "750"
  7.         Option "EmulateThirdButtonThreshold" "30"
  8.         Option "InvertX" "True"
  9.         Option "InvertY" "True"
  10. EndSection
Copy the Code
With all these settings I now have a completely rotated screen with all input devices also rotated.

DaveTheMinion replied at Tue Dec 2, 2014 18:16
Here is what I did to rotate my 7-inch touchscreen:

1. Edit /boot/uEnv.txt

Hi,
It works well, even with the 3.5 bpi display !
Thank you

DaveTheMinion replied at Tue Dec 2, 2014 18:16
Here is what I did to rotate my 7-inch touchscreen:

1. Edit /boot/uEnv.txt

Thanks for the awesome reply!!!!
I was searching for this.
To save another person a headache to:
FBDEV_ROTATE_NONE=0, FBDEV_ROTATE_CW=270, FBDEV_ROTATE_UD=180, FBDEV_ROTATE_CCW=90

Hello guys. Nothing of this worked for me. How can I troubleshoot it? My system is Raspbian for banana pro and LCD Module with TD 7''

To summarize what I've tried:
1) create and edit /boot/config.txt - that seems working only on raspbians for raspberries
2)xrandr does not work because there is only default output and for it rotation is not supported
3)editing /boot/uEnv.txt with fbcon parameter does not make any changes (but editing this file I could change resolution)
4)"Create /etc/X11/xorg.conf.d/02-monitor.conf" with data provied in upper messages does not make any changes
5)Create and edit /etc/X11/xorg.conf with data provied in upper messages does not make any changes

I only could change rotation of console output without X with command: echo 1 | sudo tee /sys/class/graphics/fbcon/rotate_all . But I need 180 degree rotation for desktop or even better for my app that I run on display=:0 with X but without window manager.


I at my wits end guys. Please help. I start to think that this feature is broken for Banana LCD module.

You have to log in before you can reply Login | Sign Up

Points Rules