Trouble

usbnet (USB tethering) won't work on Banana Pi kernel

0 1647
ddurdle  
Some background information first.

In the past I used a raspbian image on a raspberry pi to tether with two android phones.  No issues.

In the past 12 months, I upgraded to a cubieboard2.  I took the same raspbian image and just updated the boot with the boot image for cubieboard.  I used this to tether the same way as on raspberry pi.  No issues.

I am trying to replace the cubieboard2 with original Banana Pi.  Issues.

If I use the cubieboard2 boot kernel image, ethernet does not work, sd card does not show up with fdisk -l, no blue LED, but wifi and tethering to android phones with usbnet worked.  I believe ethernet doesn't work when using cubieboard2 image because it only supports EMAC and banana pi uses GMAC.

When I sub in banana pi boot image (script.bin, uImage), ethernet and sd card work, but usb tethering does not work.  usbnet doesn't appear to be supported as there are no usb0 or usb1 enteries in ifconfig.  The devices show up with dmesg when I connect and disconnect them, but no enteries in ifconfig.  I've tried many times.

Remember, I'm using the same two phones, same hd and raspbian image that worked with raspberry pi and cubieboard2.  Like I said, it works if I use the cubieboard2 kernel (from July 2014).  It simply doesn't work when I boot up using Banana Pi kernel image from August 1, 2015 provided in raspbian image on lemaker download site.

Anyone know why or how to fix?

[ 3427.474467] usb 3-1.4: Product: C5306
[ 3427.477438] usb 3-1.4: Manufacturer: Sony
[ 3427.480933] usb 3-1.4: SerialNumber: YT910DZ3JF
[ 3676.968898] usb 3-1.4: USB disconnect, device number 10
[ 3680.292871] usb 3-1.4: new high-speed USB device number 11 using sw-ehci
[ 3680.402049] usb 3-1.4: New USB device found, idVendor=0fce, idProduct=0195
[ 3680.408344] usb 3-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3680.411026] usb 3-1.4: Product: C5306
[ 3680.414004] usb 3-1.4: Manufacturer: Sony
[ 3680.417503] usb 3-1.4: SerialNumber: YT910DZ3JF
[ 3686.441121] usb 3-1.4: USB disconnect, device number 11
[ 3686.680641] usb 3-1.4: new high-speed USB device number 12 using sw-ehci
[ 3686.791884] usb 3-1.4: New USB device found, idVendor=0fce, idProduct=7195
[ 3686.798148] usb 3-1.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3686.800803] usb 3-1.4: Product: C5306
[ 3686.803769] usb 3-1.4: Manufacturer: Sony
[ 3686.807253] usb 3-1.4: SerialNumber: YT910DZ3JF


You have to log in before you can reply Login | Sign Up

Points Rules