Bananian

Powered external SATA drive does not spin up, or appear in fdisk

3 1222
I have a 4TB drive formatted as ext4 in a OWC enclosure like this: http://eshop.macsales.com/item/OWC/ME3QHKIT0GB/ It has it's own power supply.

It runs and mounts on my Raspberry Pi via USB fine.

I plugged it into my Banana Pro using a eSATA to SATA cable, but can't get it to mount. When I run fdisk -l, lsblk, or even tail -f /var/log/messages it just never appears.

I have unplugged and replugged in both sides of the connection, but still no luck.

I'm running the latest Bananian.

Any ideas?

Thanks.

If it works on Raspberry Pi but with an USB adapter, try if that way also works on Banana Pro.
If that is the case then it should be a problem with the eSata to Sata adapter.

actkk2000 replied at Thu Oct 1, 2015 20:27
If it works on Raspberry Pi but with an USB adapter, try if that way also works on Banana Pro.
If th ...

You were right. I ordered another cable and it arrived today. Everything worked without a problem.

SFluet  
Hi Steve,


I have 2 external powered USB drives; the both work with USB connection.


One of my external enclosure have an e-sata connector (Vantec).


I have tried a e-sata to sata cable from Monoprice and it does not work.


6ft SATA 6 Gbps External Shielded Cable - eSATA to SATA (Type I to Type L) - Black
Product # 8792
http://www.monoprice.com/product?p_id=8792




I dont see the drive in bananian


uname -a
Linux NAS 3.4.111-bananian #5 SMP PREEMPT Fri Mar 25 17:24:42 UTC 2016 armv7l GNU/Linux


(the drive sda1 is my other USB)

lsblk
NAME        MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
sda           8:0    0  1.8T  0 disk
└─sda1        8:1    0  1.8T  0 part /mnt/USB1800GB
mmcblk0     179:0    0   29G  0 disk
├─mmcblk0p1 179:1    0   20M  0 part
└─mmcblk0p2 179:2    0   29G  0 part /




dmesg
[ 1646.031278] ata1: exception Emask 0x10 SAct 0x0 SErr 0x10200 action 0xe frozen
[ 1646.042630] ata1: irq_stat 0x00400000, PHY RDY changed
[ 1646.051292] ata1: SError: { Persist PHYRdyChg }
[ 1646.058480] ata1: hard resetting link
[ 1646.813909] ata1: SATA link down (SStatus 0 SControl 300)
[ 1651.812593] ata1: hard resetting link
[ 1652.164332] ata1: SATA link down (SStatus 0 SControl 300)
[ 1652.173838] ata1: limiting SATA link speed to 1.5 Gbps
[ 1652.239202] ata1: hard resetting link
[ 1657.635896] ata1: link is slow to respond, please be patient (ready=0)
[ 1662.264127] ata1: COMRESET failed (errno=-16)
[ 1662.271119] ata1: hard resetting link
[ 1662.866002] ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 310)
[ 1662.877833] ata1.00: configured for UDMA/133
[ 1662.884143] ata1: EH complete



Which cable did you use ?


Thanks in advance.




You have to log in before you can reply Login | Sign Up

Points Rules