Ubuntu

Mate version: 3.10.37 SMP preempt mod_unload ARMv7 p2v8

6 2679
For compile a project is necessary headers from kernel.

Looking for headers from kernel at repository found 3.19.0 not 3.10.37 what looked for.

At Linaro site found the source stable from 3.10.37, and I use the headers to compile a project.

At first time the source compiled without SMP, and when try to use the project was printed that is necessary "3.10.37 SMP preempt mod_unload ARMv7 p2v8". At second time code adjusted to compile with SMP and after compile the version is "3.10.37 SMP mod_unload modversions ARMv7 p2v8" different of the version necessary.

If some one know or have instructions to compile projects using same version "3.10.37 SMP preempt mod_unload ARMv7 p2v8", tell us how, maybe is possible to have in repository: linux-headers of 3.10.37 and/or linux-source of 3.10.37.

hnsncxy  
Sorry, i don't understand what you said. you are use the kernel from the Linaro ?

Same for me...
It's not clear what you try to achieve!

Edited by hcalencar at Nov 10, 2015 05:34

Thanks for reply.

No I am not using kernel from Linaro.The kernel from Linaro was downloaded to generate headers 3.10.37.

For compile a specific project is necessary the use of headers from kernel.

The configuration of the Linux kernel at moment is: "3.10.37 SMP preempt mod_unload ARMv7 p2v8"

After install Ubuntu Mate, at directory /lib/modules/3.10.37, have 2 links build and source that are going to /home/peter/s500_v5/linux-actions-bsp/build/s500_lemaker_guitar/linux and /home/peter/s500_v5/linux-actions-bsp/linux respectively. Is necessary create new links for source or headers. So I try to use the same version of kernel, but not found at repository, what I found was the version 3.10.37 at Linaro in Internet.

The source was compiled, then when try to use the project was printed that is necessary "3.10.37 SMP preempt mod_unload ARMv7 p2v8" because the code compiled was "3.10.37 preempt mod_unload ARMv7 p2v8". At second time code adjusted to compile with SMP and after compile the version is "3.10.37 SMP mod_unload modversions ARMv7 p2v8" different of the version necessary.

Edited by hcalencar at Dec 01, 2015 07:38

It's necessary generate the headers from kernel using Lemaker Guitar BSP.

* SO changed from Ubuntu Mate to Lemuntu V1511;
* Compile Linux kernel and u-boot, using instructions http://wiki.lemaker.org/LeMaker_ ... Maker_Guitar_BSP/en (in a machine with Cross-compile in my case Ubuntu14.04LTS);
* Transfer the generated code to Guitar;
* Generate a modpost file for Guitar (make linux);
* Link the source and build files from Linux kernel (/lib/modules/3.10.37/) to .../linux-actions-bsp/build/s500/linux and .../linux-actions-bsp/linux-actions, respectively;

Compile the project that headers from kernel is necessary.

In general, when we compile drivers modules or the project that uses kernel header files, it is necessary to use   the head files from the running Linux kernel(3.10.37).

jinyi831
Une semelle extérieure en caoutchouc robuste et un échantillon de crampons garantissent une traction maximale sur asics equipe de france le gazon et le terrain. Le premier utilise Phylite pour envelopper la coquille de mousse Lunarlite. Avant de nettoyer, vous êtes censé connaître les matériaux de l'empeigne. Le Vulcan est un briquet solide à flamme triple. Le facteur le plus important lors de la recherche de votre robe est de garder son calme! Chaque petite chose se retrouvera dans la clôture, même si cela prend plus de temps que vous ne le pensiez. Le pommeau était fixé à sa poignée en bronze moulé avec une noix qui avait un point important qui, s'il nike internationalist femme beige était utilisé avec une force suffisante, pourrait fracturer le crâne d'un homme.

You have to log in before you can reply Login | Sign Up

Points Rules