LeMedia

Trobleshooting - booting from SD Card -Newbie question

2 1279
finger  
Hi,
After playing with Android i decided to run LeMedia from SD CARD without success, can someone pinpoint what i am doing wrong?

I followed the instructions:
* Downloaded LeMedia_For_Guitar_SD_v1511.img (http://mirror.lemaker.org/Lemuntu_For_Guitar_SD_v1511.7z)
* Flashed a 16 GB sd card with:
sudo dd_rescue -A ~/Downloads/LeMedia_For_Guitar_SD_v1511.img /dev/sdc (with success)
* Inserted the SD card into Guitar and powered it on with 12v 5A

Guitar boots always from EMMC, so what am i missing?
finger  
Can someone share you boot log with sd card?Here is my boot log from EMMC and with sd card inserted.
What is the boot sequence for the Guitar?

with SD CARD inserted:
bus_id 0
bus_mfp 0
pmu_id 3
vddr_pmu_dcdc_cfg 5
ddr_clk 588
ddr_cap 1024
ddr_bits_width 0
rank 1
ddr_type 0
row_col 0
rdodt 1
wrodt 1
zpzq 12
uart_id 3
uart_baudrate 115200
uart_pad 0
jtag_pad 0
bootdev 34
version 1.1
scan 0
busid = 0bus_mfp = 0pmu_id = 3vddr_pmu_dcdc_cfg = 5
ddr_clk = 0x24c ddr_cap = 400 ddr_bits_width = 0 rank = 1 ddr_type = 0 row_col = 0 rdodt = 1   wrodt = 1 zpzq = c, row_col_detect = 68  
consolse init :port  3, baudrate 115200 mfp 0
pmu init
busid = 0bus_mfp = 0pmu_id = 3vddr_pmu_dcdc_cfg = 5
g_current_bus = 00x51:0x8d2:0x8d2
0x39:0x325b:0x325b
0x14:0x88a
VERSION A:set val = 0x85af
0x14:0x85af:0x85af
0x62:0x0
0x15:0x6cae:0x6cae
0x16:0x334b:0x334b
ATC2609A_PMU_SYS_CTL3 = 16512
,s2 flag = 0
enter from s40x3f:0x1e3:0x1e3
check adfu
reg_val = 0x0ddr init
ddr_cap = 400  row_col = 0 row_col_detect = 68  
DRAM init mode0,type0,1cs,x32,588MHz,0x334d.@150616_R...Ok:1024MByte Cap.
ddr size=1024MB
load app
load uboot: load address is 0x8000000, entry point is 0x8000040
in fourth
dvfs = 0xc583bb75
ddr scan = 0
dvfs maigc = 0x44564653, dvfs = 0xc583bb75

U-Boot 2015.04 (Oct 19 2015 - 17:43:08)Actions-Semi

DRAM:  mem-size=1024MB
1 GiB
PLL:core=0x332,dev=0x1164,bus=0x1c710000,bus1=0x2e004,display=0x164, spead=0x0
set kinfo addr = 3f700000
gpio=23,mode=0,val=0
gpio=25,mode=0,val=0
gpio=55,mode=0,val=0
pwm_init, blob 3defef08
PWM init, node 3684
not find HOSC dat = 0xffff
not find HOSC dat = 0xca
ret = 7104
owl: begin analysis pmu in device tree
node = 9300
owl: have for pmu in device tree , node =9300
pmu_config.bus_id = 0
pmu_config.dcdc_en_bm  = 14
pmu_config.dcdc_cfgs[0] = 0
pmu_config.dcdc_cfgs[1] = 11
pmu_config.dcdc_cfgs[2] = 10
pmu_config.dcdc_cfgs[3] = 5
pmu_config.ldo_en_bm  = 131
pmu_config.ldo_cfgs[0] = 1
pmu_config.ldo_cfgs[1] = 2
pmu_config.ldo_cfgs[2] = 0
pmu_config.ldo_cfgs[3] = 0
pmu_config.ldo_cfgs[4] = 0
pmu_config.ldo_cfgs[5] = 0
pmu_config.ldo_cfgs[6] = 0
pmu_config.ldo_cfgs[7] = 3
pmu_config.ldo_cfgs[8] = 0
pmu_config.ldo_cfgs[9] = 0
pmu_config.ldo_cfgs[10] = 0
pmu_config.ldo_cfgs[11] = 0
pmu_type = 2
pmu_config.pwm_config[0].pwm_val = 0x0
pmu_config.pwm_config[0].mfp.shift = 0
pmu_config.pwm_config[0].mfp.mask = 0
,pmu_config.pwm_config[0].mfp.val = 0
pmu_config.pwm_config[0].mfp.no = 0
pmu_config.pwm_config[1].pwm_val = 0x102c3f
pmu_config.pwm_config[1].mfp.shift = 38
pmu_config.pwm_config[1].mfp.mask = 7
,pmu_config.pwm_config[1].mfp.val = 3
pmu_config.pwm_config[1].mfp.no = 1
pmu_config.pwm_config[2].pwm_val = 0x10343f
pmu_config.pwm_config[2].mfp.shift = 38
pmu_config.pwm_config[2].mfp.mask = 7
,pmu_config.pwm_config[2].mfp.val = 3
pmu_config.pwm_config[2].mfp.no = 1
pwm1 val=0x102c3f
pwm2 val=0x10343f
0x51:0x8d2:0x8d2
0x39:0x325b:0x325b
dcdc_cfgs[1] = 11
0x11:0xe5cf:0xe5cf
0x12:0x2cae:0x2cae
0x13:0x334b:0x334b
0x17:0x8acf:0x8acf
0x18:0x254c:0x254c
0x19:0x338a:0x338a
pmu init finish!
begin to check power!
wall_mv=4204
----------the plug_stat is 0-NO_PLUG,1-WALL_PLUG,2-USB_PLUG:1
----------bat_voltage = 52
bat_mv:52
node_path[2]=/i2c@b0170000/atc2603c@65/atc260x-power
support type: both DCIN and USB
low_power_boot_choice is 0
support_minicharger:1
MMC:   ERROR: v7_dcache_inval_range - stop address is not aligned - 0x3defd548
error: SDC2 send CMD8, No rsp
error: SDC2 send CMD55, No rsp
SD0: 0 (SD), eMMC: 1 (eMMC)
Using default environment

bootmode = 0
emmc boot
** File not found recovery/command
get_partition_info_efi: Invalid Argument(s)
Failed to register mmc: 0:0
not find update.zip, ret=0
bootlogo: if=mmc, dev=1
reading boot_logo.bmp.gz
reading new_gamma_data
Fail to load gamma
OWL VIDEO: power on
OWL VIDEO: wait res 998, 113301
OWL LCD: lcd init
fdtdec_get_lcd_par
fdtdec_pwm_get: fdtdec_pwm_get(3defef08, 8560, pwms, 0)
pwm_node=e64, pwm_chip.pwm_node=e64
pwm id = 0
pwm period = 50000
pwm polarity = 1
OWL dsi: dsi init
buf->vaddr  0x3df04370 buf->paddr  0x3df04370
fdtdec_get_dsi_par0
Can't get dsi mode node
OWL dsi: fdt No dsi par
fdtdec_get_hdmi_par
fdtdec_get_hdmi_par: resolution  = 1080P60HZ
fdtdec enable lcd
get_pwr_ctl lcd_power_gpios  0
get_pwr_ctl lcd_reset_gpios  0
reset ok lcd_reset_gpios
pwm:request duty = 14648
pwm:request period_ns = 50000
open bl 1
fdtdec enable lcd ok 1
In:    serial
Out:   serial
Err:   serial
cannot locate keyboard node
adc_val=138
Net:   owl_mac_parse_fdtdec,phy_addr 1
owl_mac_parse_fdtdec,power-gpio 43
owl_mac_parse_fdtdec,reset-gpio 127
owl_mac
Error: owl_mac address not set.
, usb_ether
Error: usb_ether address not set.

Enter s500 to abort autoboot in 2 seconds
boot from emmc card ...
reading uEnv.txt
81 bytes read in 3 ms (26.4 KiB/s)
Loaded environment from uEnv.txt
Running uenvcmd ...
reading boot.scr
** Unable to read file boot.scr **
reading uImage
5619440 bytes read in 239 ms (22.4 MiB/s)
reading ramdisk.img
2018790 bytes read in 88 ms (21.9 MiB/s)
reading kernel.dtb
34205 bytes read in 5 ms (6.5 MiB/s)
## Booting kernel from Legacy Image at 00007fc0 ...
   Image Name:   Linux-3.10.37
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    5619376 Bytes = 5.4 MiB
   Load Address: 00008000
   Entry Point:  00008000
   Verifying Checksum ... OK
## Loading init Ramdisk from Legacy Image at 01ffffc0 ...
   Image Name:   RAMFS
   Image Type:   ARM Linux RAMDisk Image (uncompressed)
   Data Size:    2018726 Bytes = 1.9 MiB
   Load Address: 02000000
   Entry Point:  02000000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 04000000
   Booting using the fdt blob at 0x4000000
   XIP Kernel Image ... OK
   Using Device Tree in place at 04000000, end 0400b59c
owl_boot_fdt_setup android
read_mi_head, line 429, magic 0x0, length 0, item num 0
read Head null
read SN failed
cmdline: console=ttyS3 earlyprintk clk_ignore_unused selinux=0 androidboot.dvfslevel=0x705x androidboot.bootdev=sd boot_dev=sd2

finger  
Edited by finger at Dec 08, 2015 06:29

hange, Thanks for the reply.

I will try 2) first, if not, 1)
Update:
* Pressing AFDU on the core board boots from SD CARD, but i think is too risky, better update eMMC.

Anyways, 2) Works!

You have to log in before you can reply Login | Sign Up

Points Rules