Bananian

M1+ brick after reboot

14 2082
szendo  
Hi, i have bananapi M1+ and bananian 15.08.
Always, 3-4 days after installation of bananian 15.08, when i try to reboot, banana pi have a problem with starting. Something wrong with filesystem. Then i must write the image again.

Does anyone else have the same problem?
Help me

The power adapter or the sdcard is where you should start.

Try with a different/better power supply and a branded class10 sdcard.

szendo  
I tried with samsung 2A and  nokia 2A charger.
I use Kingston 16gb class10.  
So, which card is better?
Maybe it's problem with bananian? Did you know any  similar linux ?

igorpec  
Edited by igorpec at Dec 27, 2015 10:01

Check Armbian.
If this will not help, you got some hardware problem.

szendo  
Armbian has some problem with python;/

I cant compile python ( gcc: error: unrecognized command line option '-V' )
and i cant install cryptography (  Setup script exited with error: command 'arm-linux-gnueabihf-gcc' failed with exit status 1 )

igorpec  
Edited by igorpec at Dec 29, 2015 18:56

problems with python?

What you probably experience is a compiler compatibility problems or you are simply doing something wrong.

If you use Debian Wheezy base, than there is one particular compiler, Jessie have other and Ubuntu Trusty another.

If this is a general compiler issue it's not a direct problem of Armbian. We are using default Debian / Ubuntu armhf package base + some ours, system fine tuning, kernel and u-boot. Generally I tend to fix such base system problems.

No changes in default compiler or Python stuff.






szendo  
Edited by szendo at Dec 30, 2015 02:12

Yes, it's just a problem with gcc compiler.
I lost a lot of time and i didn't find any simple solution.
Armhf  gcc from armbian isn't fully compatible with standard gcc and python 3.4 can't build and install packet by pip.

igorpec  
Armbian come in three different basis - Debian Wheezy, Jessie and Trusty.  I am using Python on some projects and it's working fine out of the box - http://forum.armbian.com/index.p ... turbo-installation/

The main question remain. Which base are you using? Than we can maybe find a solution.

Compiler, used in Armbian is standard Debian / Ubuntu. If it's broken in Debian / Ubuntu is broken here.

szendo  
I have Jessie.
On bananian Jessie  all works fine.

igorpec  
Jessie, I assume kernel 3.4.x? ... exactly which steps lead you to this error.

I hope you are not bothered. If there is an issue I want to know about it and fix it.

You have to log in before you can reply Login | Sign Up

Points Rules